【问题标题】:cannot starting start-dfs.sh in hadoop environment hadoop-env.sh problem?在 hadoop 环境 hadoop-env.sh 问题中无法启动 start-dfs.sh?
【发布时间】:2019-07-29 03:40:07
【问题描述】:

我尝试在我刚刚尝试创建的 hadoop 环境中启动 start-dfs.sh,但我收到了这条消息,我不知道这是什么意思.. 谁能帮帮我,

/usr/local/hadoop/etc/hadoop/hadoop-env.sh: line 300: /usr/local/hadoop/logs: 是目录 /usr/local/hadoop/etc/hadoop/hadoop-env.sh:第 301 行:Java:找不到命令 在 [master] 上启动名称节点 错误:HADOOP_WORKERS 和 HADOOP_WORKER_NAMES 都已定义。中止。 启动数据节点 警告:HADOOP_SECURE_DN_LOG_DIR 已被 HADOOP_SECURE_LOG_DIR 替换。使用 HADOOP_S ECURE_DN_LOG_DIR 的值。 本地主机:ubuntu@localhost:权限被拒绝(公钥)。 启动辅助名称节点 [ip-172-31-93-240] 错误:HADOOP_WORKERS 和 HADOOP_WORKER_NAMES 都已定义。中止。

【问题讨论】:

    标签: hadoop


    【解决方案1】:

    注释或删除 $HADOOP_HOME/etc/hadoop/hadoop-env.sh 中的这一行(或者您可能在 bashrc 等其他文件中定义了此环境变量):

    export HADOOP_WORKERS="${HADOOP_CONF_DIR}/workers"

    然后,取消设置 HADOOP_WORKERS 环境变量:

    $ HADOOP_WORKERS=''
    

    【讨论】:

    • 请添加更多详细信息以扩展您的答案,例如工作代码或文档引用。
    猜你喜欢
    • 2016-02-15
    • 1970-01-01
    • 1970-01-01
    • 2021-01-28
    • 2020-05-27
    • 1970-01-01
    • 2016-04-22
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多