【问题标题】:Increasing Eden space heap size tomcat增加 Eden 空间堆大小 tomcat
【发布时间】:2019-03-01 04:59:31
【问题描述】:

我当前的tomcat配置如下图

下面提到了我的tomcat配置变量-

export CATALINA_OPTS="$CATALINA_OPTS -Xms512m"
export CATALINA_OPTS="$CATALINA_OPTS -Xmx12288m"
export CATALINA_OPTS="$CATALINA_OPTS -Xmn8192m"
export CATALINA_OPTS="$CATALINA_OPTS -XX:NewRatio=1"
export CATALINA_OPTS="$CATALINA_OPTS -XX:SurvivorRatio=4"
export CATALINA_OPTS="$CATALINA_OPTS -XX:+ScavengeBeforeFullGC -XX:+CMSScavengeBeforeRemark"
export CATALINA_OPTS="$CATALINA_OPTS -Xloggc:/opt/tomcat/logs/gc_$(date +%d-%m-%y-%H-%M).log -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps"

上述配置的分配在上图中得到了很好的体现。 Young Generation HeapSize 大约是 8GB,Old Generation Heap size 如果是 4GB。看起来都不错。但是我检查了gc logs,发现当伊甸园空间满 1GB 时会触发垃圾收集

2019-02-27T06:26:48.881+0000: 1027.464: [GC (Allocation Failure) [PSYoungGen: 1247052K->30885K(1296896K)] 1283550K->67399K(1360896K), 0.0245425 secs] [Times: user=0.09 sys=0.03, real
=0.02 secs]
2019-02-27T06:28:08.578+0000: 1107.161: [GC (Allocation Failure) [PSYoungGen: 1183909K->31338K(1438720K)] 1220423K->67860K(1502720K), 0.0354672 secs] [Times: user=0.12 sys=0.03, real
=0.03 secs]
2019-02-27T06:29:32.316+0000: 1190.899: [GC (Allocation Failure) [PSYoungGen: 1378672K->31886K(1312768K)] 1415194K->68416K(1376768K), 0.0237727 secs] [Times: user=0.10 sys=0.00, real
=0.03 secs]
2019-02-27T06:30:17.752+0000: 1236.335: [GC (Allocation Failure) [PSYoungGen: 1312398K->31671K(1286144K)] 1348928K->68209K(1350144K), 0.0240825 secs] [Times: user=0.12 sys=0.01, real
=0.02 secs]
2019-02-27T06:31:01.988+0000: 1280.571: [GC (Allocation Failure) [PSYoungGen: 1248695K->31838K(1188864K)] 1285233K->68385K(1252864K), 0.0288038 secs] [Times: user=0.15 sys=0.00, real
=0.03 secs]
2019-02-27T06:31:44.973+0000: 1323.555: [GC (Allocation Failure) [PSYoungGen: 1188446K->31749K(1166848K)] 1224993K->68295K(1230848K), 0.0231320 secs] [Times: user=0.13 sys=0.00, real
=0.02 secs]
2019-02-27T06:32:26.203+0000: 1364.786: [GC (Allocation Failure) [PSYoungGen: 1131013K->32025K(1077248K)] 1167559K->68579K(1141248K), 0.0351297 secs] [Times: user=0.14 sys=0.00, real
=0.03 secs]

我很困惑为什么eden space 在执行Young GC 之前没有占用完整的 7GB 空间。从日志中可以看出,gc 每 2 分钟触发一次,并且每个 gc 调用都在为30 milli-seconds 暂停系统。是否可以充分利用分配的堆空间。

【问题讨论】:

  • 您指定的初始堆大小为 512M。这意味着您不希望 JVM 在可以避免的情况下使用完整空间。

标签: tomcat garbage-collection jvm tomcat8


【解决方案1】:

在生产系统上,我的建议是使用相同的 -Xms 和 -Xmx 值,因为在启动时您要确保最大允许内存是可用的。您不希望周日晚上凌晨 3 点分配最后 2G 内存失败。这与 Holger 的评论相吻合:您正在指定您不希望 JVM 分配所有内存 - 它遵守了这个愿望。

另一方面:GC 被抽象掉了,很少有理由关心它的细节。从应用程序的角度来看,您不知道它何时实际出现 - 它可能是在低负载时间、每 2 分钟一次或内存几乎已满时。

对于某些 GC 算法和应用程序,建议确定应用程序所需的最小内存量,添加一点点开销并对其进行配置,因为更频繁的短 GC 运行比不太频繁的长时间运行更好。如果这仍然存在于您正在使用的 GC 中,并且对于您的应用程序,还有待查明。

应该根据应用程序的需要而不是根据碰巧可用的内存来授予应用程序内存。

  • 如果您需要 12G:继续,使用-Xms 分配它们。
  • 如果您只提供 12G 来解决内存泄漏问题:请修复该问题。
  • 如果您只提供 12G 是因为您的服务器上有这么多可用内存:找出您的应用需要什么,然后分配 该数量(加上一些余量)

关于开发系统:何必呢?

【讨论】:

    猜你喜欢
    • 2014-10-24
    • 2011-01-14
    • 1970-01-01
    • 1970-01-01
    • 2012-06-17
    • 2010-10-16
    • 2012-05-03
    • 1970-01-01
    • 2012-12-07
    相关资源
    最近更新 更多