【问题标题】:Logstash elasticsearch https output filterLogstash elasticsearch https 输出过滤器
【发布时间】:2017-02-23 15:07:36
【问题描述】:

使用 logstash 2.2 docker 容器将本地应用程序日志数据发送到 AWS Elasticsearch v5.1 集群并希望此流量使用 HTTPS 但失败。

我在 /etc/logstash/conf.d/logstash.conf 文件中尝试了以下条目:

output {
  elasticsearch {
    hosts => "https://my-aws-es-domain.es.amazonaws.com:443"
  }
}

还有:

hosts => "https://my-aws-es-domain.es.amazonaws.com"
hosts => "my-aws-es-domain.es.amazonaws.com:443"

我在 logstash 日志中看到的错误消息是:

message=\u003e\"my-aws-es-domain.es.amazonaws.com:443 failed to respond\"

如果我使用 http 和端口 80,它可以正常工作。

谁能建议通过 HTTPS 将日志数据发送到 ES 的正确值?

【问题讨论】:

  • 你能定义“...但失败”吗?
  • 从日志中添加了logstash错误消息。

标签: amazon-web-services elasticsearch filter output logstash


【解决方案1】:

我的猜测是您在 elasticsearch output 中遗漏了 ssl 概要:

output {
  elasticsearch {
    hosts => "https://my-aws-es-domain.es.amazonaws.com:443"
    ssl   => true
  }
}

引用文档:

如果此处明确禁用 SSL,则插件将拒绝启动 在 hosts 中给出了一个 HTTPS URL

希望这会有所帮助!

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2017-07-04
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多