【发布时间】:2018-02-23 15:08:45
【问题描述】:
我们在生产环境中遇到了以下问题: 当我们在 IIS Server 8.5 (Using IISCrypto) 中禁用一些弱加密时,在我们尝试登录网页后,服务器显示 401 错误
我们尝试配置的加密和密码是这样的
我们应用更改并重新启动服务器后的错误是这样的
但是,当我们在我们的 QA 环境中应用相同的更改并且我们没有遇到这个问题时,事实上,我们检查了两个环境中的 IIS 是否具有不同的配置,但配置仍然是相同的两种环境。如果我们反转更改并启用所有 Crypto 算法,问题就会消失
我们还检查了我们的 Web.config 以检查两个环境的身份验证方法是否不同,但是,这两行完全相同
<authentication mode="Forms">
<forms timeout="20" loginUrl="Login.aspx" defaultUrl="Login.aspx" requireSSL="true" />
</authentication>
<authorization>
<deny users="?" />
<allow roles="Admin, User" />
</authorization>
有人可以帮我们解决这个问题吗?我们寻找的任何变通方法和解决方案都不起作用或它们不适用(主要是因为我们没有在我们的网站中使用 Windows 身份验证)
提前致谢
编辑:匿名身份验证在双方都有相同的配置
【问题讨论】:
标签: authentication iis cryptography windows-server-2012-r2 http-status-code-401