【问题标题】:Service Fabric "Container deployment is not supported on the node" on Azure StackAzure Stack 上的 Service Fabric“节点上不支持容器部署”
【发布时间】:2022-01-07 23:12:19
【问题描述】:

我们正在尝试在 Azure Stack 上运行的 Service Fabric 上部署 Docker 容器。 不幸的是,它经常失败并显示错误消息Container deployment is not supported on the node。容器没有被拉出,甚至没有启动。

我们看不出容器无法启动的任何原因:

  • 主机操作系统是“WindowsServer2016 DataCenter with Containers”
  • 我们可以登录节点并成功拉取并执行节点上的容器
  • 所有容器都有问题
  • 我们尝试了 hyperv 和进程隔离模式

我们已经在云中设置了完全相同的配置,并且容器执行没有问题:

  • 相同的操作系统版本甚至内部版本号:版本 1607 内部版本 14393.4825
  • 相同的 ServiceFabric-版本:8.2.1363.9590

有人知道这个问题吗?可能与使用 Azure Stack 有关吗?

【问题讨论】:

    标签: azure-service-fabric azure-stack


    【解决方案1】:

    我们自己想通了。必须检查集群清单,是否有一个名为“DisableContainers”的属性。在我们的例子中,它设置为 true,因此不允许在集群节点上部署容器。使用正确的设置通过 PowerShell 更新服务清单解决了该问题。

    诀窍是,官方MS docs 告诉我们默认值为 FALSE。由于其默认状态,该属性未在我们的公共集群中列出。 另一方面,在 Azure Stack 上,即使您显式部署在支持 Docker 的节点上,它也会被设置为 TRUE。

    【讨论】:

      猜你喜欢
      • 2019-02-06
      • 1970-01-01
      • 2016-11-24
      • 1970-01-01
      • 2020-02-12
      • 2016-02-14
      • 2018-03-06
      • 2017-03-29
      • 2020-03-11
      相关资源
      最近更新 更多