【问题标题】:Caddy server with proxy to hugo server failing to load CSS具有代理到 hugo 服务器的 Caddy 服务器无法加载 CSS
【发布时间】:2018-04-12 03:20:01
【问题描述】:

我正在安装 debian 的 linode 实例上运行 caddy 服务器。我正在使用 caddy 服务器代理到一个 hugo 服务器。 hugo 服务器在本地工作,但不通过 caddy 服务器。它将加载内容,但 style.min.css 和网站图标不会加载,并出现如下错误:

GET https://localhost:8081/css/style.min.cssnet::ERR_CONNECTION_REFUSED

任何帮助让这个工作会很棒!

球童文件:

mycustomdomain.com {
  root /home/sean/mycustomdomain.com
  gzip
  proxy / localhost:8081
  tls {
    dns linode
  }
}

hugo 命令:

hugo server --disableLiveReload --port 8081

【问题讨论】:

  • 为什么要代理到一个 hugo 服务器,尤其是在没有启用实时重载的情况下?为什么不让 Caddy 提供静态文件?
  • hugo 服务器实际上是通过 https 服务的吗?
  • @matt 因为 hugo 不是我将在我的 linode 盒子上提供的唯一东西。 liveReloading 与这个问题无关。
  • @TobyAllen 我的印象是 hugo 自动通过 https 提供服务,但我不确定如何确认,除了它只说它正在服务 Web Server is available at http://localhost:1313/ (bind address 127.0.0.1) 似乎不是 https .
  • Hugo 默认不提供 HTTPS。只有 Caddy 这样做。

标签: linode hugo caddy caddyfile


【解决方案1】:

想通了,所以回答后人:

要解决此问题,请使用 http.hugo 插件。新的Caddyfile 看起来像这样:

mycustomdomain.com {
  root /hugo/site/dir/public
  hugo /hugo/site/dir
  gzip
  tls {
    dns linode
  }
}

【讨论】:

猜你喜欢
  • 1970-01-01
  • 2018-10-29
  • 1970-01-01
  • 2015-12-02
  • 2015-07-15
  • 2015-07-23
  • 2014-03-10
  • 2017-06-25
  • 1970-01-01
相关资源
最近更新 更多