【问题标题】:Caddy 2 not running in Docker: "cannot assign requested address"Caddy 2 未在 Docker 中运行:“无法分配请求的地址”
【发布时间】:2020-05-22 22:16:24
【问题描述】:

我正在尝试运行the official Caddy 2 docker image。根据该页面,为此您应该运行:

docker run -p 80:80 \ 
    -v $PWD/index.html:/usr/share/caddy/index.html \
    -v caddy_data:/data \
    caddy

当我运行它时,我收到以下错误:

{"level":"info","ts":1590185286.853735,"msg":"使用提供的配置","config_file":"/etc/caddy/Caddyfile","config_adapter":"caddyfile"} 运行:加载初始配置:加载新配置:启动球童管理端点:监听 tcp 45.90.28.0:2019:绑定:无法分配请求的地址

我不知道为什么它会默认绑定到那个 IP 地址?我尝试在 Caddyfile 中更改它,但它仍然无法正确绑定,而且无论如何这并不能真正解决这里的根本问题。

什么可能导致这个问题?我应该改用 Caddy 1 吗?

【问题讨论】:

  • 我遇到了类似的问题。你在运行 Fedora 32 吗?
  • 否,在 macOS 上运行。如果它也可以在 Fedora 上运行,那就太好了,因为我也使用它,但我还没有在那里尝试过。
  • 如果您在浏览器中输入 localhost,会显示球童欢迎页面?为了运行,Caddy 使用 /etc/caddy/ 中的 Caddyfile。我遇到了这样的问题,我通过覆盖 Caddyfile 解决了它。
  • @DiegoMagalhães 我在使用 Caddyfile 时遇到了同样的错误,但我想我会使用这个命令让人们更容易重现这个问题。

标签: caddy


【解决方案1】:

我最近在 Linux 上遇到了这个问题,根本原因是我的 ISP 提供的路由器 DNS 服务器将 localhost 解析为不正确的 IP 地址。

您可能想尝试将 DNS 服务器更改为 Cloudflare 的 1.1.1.1 或 Google 的 8.8.8.8 服务器。

【讨论】:

  • 谢谢。我实际上尝试过,但它在 mac 上并没有什么不同,但希望这对某人有所帮助。
猜你喜欢
  • 2021-11-03
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2012-11-30
  • 2016-12-16
  • 2021-05-19
相关资源
最近更新 更多