【问题标题】:Docker refusing connection on port 443Docker拒绝端口443上的连接
【发布时间】:2019-04-02 08:11:15
【问题描述】:

我正在设置我的 AWS EC2 实例。我想让该实例通过https 访问,但我得到了一个

这是我试过的

运行docker pull abiosoft/caddy

将 Caddyfile 放入主文件夹

运行mkdir -p $HOME/caddycerts; chmod ugo+rwx $HOME/caddycerts;

运行docker run -d -e "CADDYPATH=/etc/caddycerts" -v $HOME/Caddyfile:/etc/Caddyfile -v $HOME/caddycerts:/etc/caddycerts -p 443:443 abiosoft/caddy

运行docker restart *dockerName*

我的 Caddyfile 如下所示:

some-domain-name.com {
    tls myemail
    proxy / 172.17.0.1:9001 {
        header_upstream Host {host}
        header_upstream X-Real-IP {remote}
        header_upstream X-Forwarded-Proto {scheme}
    }
}

错误:curl: (7) 无法连接到 some-domain-name.com 端口 443:连接被拒绝

EC2 实例的安全组为端口443 启用了https

【问题讨论】:

    标签: docker amazon-ec2 caddy caddyfile


    【解决方案1】:

    当您使用 AWS 时,请确保您使用的端口是允许的并且您有权使用它

    【讨论】:

      【解决方案2】:

      AWS 安全组和 ACL 不会拒绝连接,它们会默默地丢弃数据包。从消息连接被拒绝,似乎服务没有运行或服务器没有在端口 443 上侦听。 您是否尝试过在本地远程登录?有用吗?

      远程登录本地主机 443

      【讨论】:

      • 这就是我得到的Trying 127.0.0.1... Connected to localhost. Escape character is '^]'. Connection closed by foreign host.
      【解决方案3】:
      Error: curl: (7) Failed to connect to some-domain-name.com port 443: Connection refused
      

      上面的错误信息意味着您的网络服务器没有在指定的 443 端口上运行。您可以简单地通过 telnet 进行验证(我在上面 James 的回答中看到)。

      从您的 caddyfile 指向端口 9001。Caddyfile 的第一行始终是要服务的站点的地址。

      如果没有看到 dockerfile,很难确定,但我想说的是,您的应用程序中没有任何配置为在 443 上运行

      【讨论】:

        猜你喜欢
        • 2016-10-18
        • 2018-09-17
        • 1970-01-01
        • 2019-07-31
        • 2018-08-09
        • 2018-10-15
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多