【发布时间】:2020-11-04 20:00:10
【问题描述】:
我创建了我的天蓝色网络应用并创建了应用注册。并将 Azure AD 连接到我的 Web 应用程序。我使用了快速安全,我还使用了客户端 ID 和客户端密码的高级安全。我知道关于这个错误有一个类似的问题。但没有明确的答案。
最可能的原因:
- IIS 收到请求;但是,在处理请求期间发生了内部错误。此错误的根本原因取决于处理请求的模块以及发生此错误时工作进程中发生的情况。
- IIS 无法访问网站或应用程序的 web.config 文件。如果 NTFS 权限设置不正确,就会发生这种情况。
- IIS 无法处理网站或应用程序的配置。
- 经过身份验证的用户没有使用此 DLL 的权限。
- 请求已映射到托管处理程序,但未安装 .NET 可扩展性功能。
你可以尝试的事情:
- 确保 web.config 文件的 NTFS 权限正确,并允许访问 Web 服务器的计算机帐户。
- 检查事件日志以查看是否记录了任何其他信息。
- 验证 DLL 的权限。
- 如果请求映射到托管处理程序,请安装 .NET 可扩展性功能。
- 创建跟踪规则以跟踪此 HTTP 状态代码的失败请求。有关为失败的请求创建跟踪规则的更多信息,请单击此处。
【问题讨论】:
标签: amazon-web-services azure azure-active-directory azure-web-app-service