【问题标题】:Kops Create Cluster fails with gossip in AWS LinuxKops 创建集群因 AWS Linux 中的八卦而失败
【发布时间】:2019-02-24 22:56:45
【问题描述】:

我正在关注https://github.com/kubernetes/kops/blob/master/docs/aws.md 中的教程 带有安装了 Amazon Linux 的引导 EC2 实例。

在我需要开始配置集群之前,一切似乎都运行良好。

运行 kops 命令为集群创建配置时出现此错误。我找不到任何关于如何解决此问题的帖子。

有什么帮助吗?

[ec2-user@ip-172-31-19-231 ~]$ kops create cluster --zones us-west-2a,us-west-2b,us-west-2c,us-west-2d ${NAME}

I0224 22:43:29.639232    3292 create_cluster.go:496] Inferred --cloud=aws from zone "us-west-2a"

I0224 22:43:29.699503    3292 subnets.go:184] Assigned CIDR 172.20.32.0/19 to subnet us-west-2a

I0224 22:43:29.699582    3292 subnets.go:184] Assigned CIDR 172.20.64.0/19 to subnet us-west-2b

I0224 22:43:29.699632    3292 subnets.go:184] Assigned CIDR 172.20.96.0/19 to subnet us-west-2c

I0224 22:43:29.699677    3292 subnets.go:184] Assigned CIDR 172.20.128.0/19 to subnet us-west-2d



error assigning default machine type for nodes: error finding default machine type: could not find a suitable supported instance type for the instance group "nodes" (type "Node") in region "us-west-2"

【问题讨论】:

    标签: amazon-web-services kubernetes kops


    【解决方案1】:

    错误表明您没有为将充当主节点和工作节点的 EC2 节点指定实例类型。

    以下是一个示例命令:

      kops create cluster --name=my-cluster.k8s.local \
      --state=s3://kops-state-1234 --zones=eu-west-1a \
      --node-count=2 --node-size=t2.micro --master-size=t2.micro 
    

    【讨论】:

      猜你喜欢
      • 2021-05-14
      • 2022-08-18
      • 2018-11-08
      • 2018-07-22
      • 1970-01-01
      • 2020-08-01
      • 2020-01-19
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多