【问题标题】:Cannot Start Weblogic Managed Server,无法启动 Weblogic 托管服务器,
【发布时间】:2010-07-05 16:59:48
【问题描述】:

我们正在运行 Weblogic 7sp6。我们有一个工作的单节点集群,有一个管理员和两个托管服务器。我们正在第二台服务器上重新创建第二个独立集群。我们重新安装了 Weblogic 并复制了所有配置文件来制作东西。它在两个集群上都是一样的。我们更改了对 IP 和主机名的所有引用。我们以前用过这种方法没有问题。

在当前情况下,我可以启动监听端口 7001,7002 的管理员。但是当我尝试启动任何一个托管服务器时,它会告诉我 myserver1/2 已经启动。 (托管服务器)。我确认 myserver 配置为使用端口 7012,7013 并且我找不到任何端口冲突,特别是因为这些确切的端口在第一个集群上工作。还有什么可以看的吗?我已经登录管理控制台,可以看到端口都是唯一的。谢谢

【问题讨论】:

  • 某处一定有配置错误,没有看到 config.xml、日志、跟踪、命令行等,似乎很难说什么。我也是第二个 duffy 的回答,在 2010 年使用 WLS 7(中间版本)听起来很奇怪。

标签: weblogic


【解决方案1】:

WebLogic 的当前版本是 10.3。我强烈建议您尽快升级您的 WebLogic,特别是如果您仍在使用经过认证的 JDK 版本。如果你运行的是 JDK 1.4,那你就疯了。

【讨论】:

  • 谢谢大家,它是 StartManagedWeblogic.cmd,它有第一个集群的 IP 用于管理 IP。也了解版本问题,而不是我称之为客户站点,他们了解风险并且不想现在升级。
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2016-11-25
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2020-12-10
相关资源
最近更新 更多