【问题标题】:Publishing DotNetNuke (DNN) website to Azure virtual machine将 DotNetNuke (DNN) 网站发布到 Azure 虚拟机
【发布时间】:2014-04-21 04:17:47
【问题描述】:

我发现自己在这里陷入困境,我希望有人可以提供一些帮助。

我收到了一个 DNN 网站,将其放入我的 Azure 虚拟机进行托管。我对 DNN 不是很熟悉,但我认为这不会太难。很遗憾,我错了。

我将 DNN 数据库移动到 Azure SQL 数据库。我将 DNN 的“httpdocs”文件夹中的所有内容都复制到了我的虚拟机上我网站的根文件夹中。我编辑了 Web 配置以将数据库连接字符串指向新的 Azure SQL 数据库。根据我第一次尝试运行网站时遇到的错误,我还必须授予 IIS 用户帐户编写者对 /app_data/ClientDependency 文件夹的权限。我以为这就是我所要做的,但是当我浏览到该网站时,我得到一个 404 页面。

我是否需要安装一些 DNN 软件才能使其正常工作?我试图通过 Web 平台安装程序 (WPI) 在我的 VM 上关闭 DNN。在 WPI 选项中,我告诉它使用远程数据库,但它一直要求我输入“sa”数据库帐户的密码才能继续。 Azure SQL 不允许您使用“sa”帐户,我无法告诉 WPI 使用不同的数据库帐户用户名。只要我将所有 httpdocs 文件上传到我的 VM 的网站根目录,我什至认为我不需要安装任何 DNN 软件,但是我在这里抓住了一根稻草。

任何人都可以就如何使其正常工作提供任何建议吗?我已经在谷歌上搜索了很长时间,但我没有想出任何东西:(

谢谢大家。

【问题讨论】:

标签: azure virtual-machine dotnetnuke azure-sql-database dotnetnuke-6


【解决方案1】:

404 错误可能是因为您的站点禁用了“管理 > 站点设置 > 站点别名 > 自动添加站点别名”设置。将站点移动到 Azure(或使用不同 URL 的其他位置)后,如果禁用该设置,则需要手动将其添加到数据库中。

  • 在 PortalAlias 表中添加一条新记录,指定虚拟机云服务名称(即 mywebsite.cloudapp.net)
  • 触摸 web.config 文件以确保重新启动应用程序池并清除缓存,因此门户别名表将再次从数据库填充到内存。

希望这会有所帮助。

【讨论】:

  • 如果缺少门户别名(即 DNN 7.2 及更高版本),响应标头将显示“未找到门户别名”类型消息
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 2014-01-27
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多