【发布时间】:2016-02-20 16:19:44
【问题描述】:
我有一个带有 Debian Jessie OS 的树莓派 2。我想远程连接到里面的postgresql。
我使用以下命令安装了 postgresql:
sudo apt-get install postgresql postgresql-contrib
然后我为 postgres 用户设置密码:
sudo -u postgres psql postgres
在 /etc/postgresql/9.4/main/pg_hba.conf 中添加以下行
host all all 192.168.1.0/24 md5
下面一行到/etc/postgresql/9.4/main/postgresql.conf
listen_addresses = '*'
最后我重启了postgresql服务:
sudo /etc/init.d/postgresql reload
sudo /etc/init.d/postgresql restart
但是当我尝试从 192.168.1.0/24 网络中的另一台电脑连接到 postgresql 服务器时,我从 pgadmin 收到“服务器不听”错误。
当我使用“netstat -an | grep 5432”命令时,什么也没有。
“sudo /etc/init.d/postgresql status”的结果是:
● postgresql.service - PostgreSQL RDBMS
Loaded: loaded (/lib/systemd/system/postgresql.service; enabled)
Active: active (exited) since Sat 2016-02-20 15:22:22 UTC; 50min ago
Process: 21070 ExecReload=/bin/true (code=exited, status=0/SUCCESS)
Process: 21119 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 21119 (code=exited, status=0/SUCCESS)
Feb 20 15:22:22 raspberrypi systemd[1]: Starting PostgreSQL RDBMS...
Feb 20 15:22:22 raspberrypi systemd[1]: Started PostgreSQL RDBMS.
所以我无法解决问题。是关于 Debian Jessie OS 还是 raspberry pi 2 或其他东西?
我刚刚在 Ubuntu 机器上做了同样的事情,一切都很好。
【问题讨论】:
-
看起来 postmaster 无法启动。可能安装过程在 initdb 失败,或者数据目录不存在/所有者错误。检查日志文件,也许还有系统日志。
-
我检查了 postgresql 日志文件。问题是磁盘空间不足。
标签: linux postgresql raspberry-pi raspbian