【问题标题】:Fails to connect to a local domain from Azure AD account无法从 Azure AD 帐户连接到本地域
【发布时间】:2021-12-27 09:27:16
【问题描述】:

所以我们公司迁移到 Azure,只迁移了部分员工。 现在,加入 AAD 的新员工正尝试连接到网络上的本地服务器,我收到下一个错误:“指定的服务器无法执行请求的操作”。

我阅读了有关 Azure AD Connect 的信息,它安装在本地服务器端以与 Azure 域一起运行。 还有其他选择吗?

【问题讨论】:

标签: azure azure-active-directory smb


【解决方案1】:

• 根据您对场景的解释,我可以假设您已将一些 AD 用户永久移动到 Azure AD,然后将他们的设备加入到 Azure AD。我在这里考虑的是您的本地本地域和您的 Azure AD 域是相同的。现在,由于您的用户在加入 AAD 的设备上使用其官方域 ID 登录,因此他们将无法访问本地本地服务器/文件共享或资源,因为他们无法验证这些 AAD 用户对这些资源的访问权限通过本地广告。因为这些服务器/资源是加入本地 AD 的域。

• 因此,为了让这些用户能够对本地 AD 进行身份验证并为他们提供对本地服务器的访问权限,他们移动到 Azure AD 的 ID 必须存在于本地 AD 中。因此,您应该通过 Azure AD Connect 应用程序将您的本地 AD ID 同步到您的 Azure AD 租户,并且在成功将它们同步到 AAD 后不应将它们从本地 AD 中删除。因此,在通过 Azure AD Connect 成功同步后,您的用户 ID 就可以在本地本地 AD 和 Azure AD 中使用,以便他们对各自环境中的资源进行身份验证。

• 此外,即使您的设备已加入 Azure AD,您也可以确保它们已加入本地本地 AD。这将确保即使在连接到您的办公室网络后,这些设备也可以通过您的本地 AD 进行身份验证和识别,并对其应用必要的特权/权限。一旦您将本地本地入站防火墙配置为允许通过本地 AD 身份验证对连接的用户和设备进行连接,您还可以通过这些设备从公共网络通过 VPN 连接到本地本地服务器/资源。

有关 Azure AD Connect 和混合 Azure AD 连接设备的配置,请参阅以下链接:-

https://docs.microsoft.com/en-us/azure/active-directory/hybrid/cloud-governed-management-for-on-premises

https://docs.microsoft.com/en-us/azure/active-directory/hybrid/how-to-connect-sync-whatis

【讨论】:

    猜你喜欢
    • 2019-06-08
    • 2019-03-29
    • 1970-01-01
    • 2019-02-01
    • 2019-10-16
    • 1970-01-01
    • 1970-01-01
    • 2023-01-11
    • 1970-01-01
    相关资源
    最近更新 更多