【发布时间】:2014-11-26 07:33:05
【问题描述】:
我写了一个简短的批处理文件,用于每晚重新启动两个服务,并将一些行写入同一文件夹中的 txt 文件。根据计划任务的历史,任务运行成功,但未创建 txt 文件。
起初我以为这是因为权限问题,但是当我将运行任务的用户对批处理文件和文件夹的权限升级到最大时,结果保持不变。
如果我手动运行批处理文件,它会做它应该做的事情。
我在这里错过了什么?
来源:
@echo off
set now=%date:~6,4%%date:~3,2%%date:~0,2%
@echo. >>servicerestartlog.txt
@echo.%now% >>servicerestartlog.txt
net stop "IntegratorService"
IF ERRORLEVEL 0 @echo STOP INTEGRATOR SUCCESS>>servicerestartlog.txt
IF NOT ERRORLEVEL 0 @echo STOP INTEGRATOR FAILED>>servicerestartlog.txt
net stop "SchedulerService"
IF ERRORLEVEL 0 @echo STOP SCHEDULER SUCCESS>>servicerestartlog.txt
IF NOT ERRORLEVEL 0 @echo STOP SCHEDULER FAILED>>servicerestartlog.txt
net start "IntegratorService"
IF ERRORLEVEL 0 @echo START INTEGRATOR SUCCESS>>servicerestartlog.txt
IF NOT ERRORLEVEL 0 @echo START INTEGRATOR FAILED>>servicerestartlog.txt
net start "SchedulerService"
IF ERRORLEVEL 0 @echo START SCHEDULER SUCCESS>>servicerestartlog.txt
IF NOT ERRORLEVEL 0 @echo START SCHEDULER FAILED>>servicerestartlog.txt
exit
【问题讨论】:
-
您没有指明日志文件的路径,因此,当前的活动目录可能不是您想的那样。
-
是的,这似乎是问题所在。看来我只需要在编辑操作以更改当前活动目录时设置“开始于”-参数。
标签: batch-file scheduled-tasks windows-server-2012