【发布时间】:2020-01-27 12:15:48
【问题描述】:
我正在将带有 helm 图表的 Jenkins 部署到 GKE 并且遇到作业问题,主要是从站看不到 tcpSlaveAgentListener - 每当我开始任何作业时都会发生 - 主站触发新 jenkins-agent 的规模但它终止有这样的错误
SEVERE: Failed to connect to http://jenkins.jenkins.svc.my_website:8080/tcpSlaveAgentListener/: jenkins.jenkins.svc.my_website
java.io.IOException: Failed to connect to http://jenkins.jenkins.svc.my_website:8080/tcpSlaveAgentListener/: jenkins.jenkins.svc.my_website
at org.jenkinsci.remoting.engine.JnlpAgentEndpointResolver.resolve(JnlpAgentEndpointResolver.java:206)
我将我的域(如 google.com)替换为 my_website - 我对 jenkins.jenkins.svc.my_domain 很好奇 - 它是内置的还是我在某处有一些重复项?它有这么多子域?
【问题讨论】:
-
嗨,slave 通过 JNLP 端口(传入代理的 TCP 端口)上的 JNLP 连接回 Jenkins。如果您将转到管理 > 配置全局安全性;你会看到的;选择固定端口并指定一个值,例如 8081。您还可以使用 kubernetes 插件配置(管理>配置系统)下的隧道并指定 jenkins.jenkins.svc:8081。 (如果您的命名空间是 jenkins 并且服务公开的名称也是 jenkins)
-
谢谢!!!解决了这个问题 - 所以在 kubernetes 插件下配置它显然不够好
-
我可以添加这个作为答案吗?你乐意投票和接受吗? :)
标签: jenkins kubernetes jenkins-pipeline