【问题标题】:docker unrecognised service when i run this command sudo service docker stop当我运行此命令 sudo service docker stop 时,docker 无法识别的服务
【发布时间】:2014-12-22 06:10:03
【问题描述】:

我正在尝试将图像推送到我自己的 docker 注册表。我收到无效的端点注册表错误。当我用谷歌搜索它时,我得到了运行这些命令的解决方案。这是我尝试运行第一个命令时的链接 Remote access to a private docker-registry,即服务docker stop 我将始终无法识别服务。其他 docker 命令运行正常。我用谷歌搜索但没有得到太多帮助。如果有人可以帮助我如何解决这个问题?

【问题讨论】:

  • 你在主机上运行什么操作系统?什么版本的 Docker?你是如何安装 Docker 的?
  • 我正在主机 ubuntu 14.04.docker 版本 1.0.1 上运行 docker。我通过运行此命令 apt-get -y install docker.io 安装了 docker

标签: docker


【解决方案1】:

是不是因为你安装了docker.io所以服务叫docker.io?
service docker.io stop 有效吗?

请参阅https://docs.docker.com/installation/ubuntulinux/ 了解如何获得更新的版本。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2017-01-13
    • 1970-01-01
    • 2018-02-11
    • 1970-01-01
    • 2016-02-10
    • 1970-01-01
    • 1970-01-01
    • 2021-09-17
    相关资源
    最近更新 更多