【发布时间】:2016-09-21 02:08:26
【问题描述】:
我正在努力寻找有关让 Phoenix(以及 Cowboy 和 Ranch)同时监听 IPv4 和 IPv6 的信息。
我正在使用 Ubuntu 16.04 的 VPS 上运行。它同时具有 IPv4 和 IPv6 地址。
当运行netstat -tulpn 时,它显示beam 只在IPv4 上侦听,端口在Phoenix 配置中指定。
而其他进程,如 epmd,能够同时监听 IPv4 和 IPv6。
我尝试在config.exs 中指定类似"::4000" 的端口,但由于无法解析为整数而崩溃。
有人能指出我正确的方向吗?我是否需要以某种方式添加自定义 Cowboy 侦听器?
我宁愿不必在前面运行 Nginx 来监听 IPv6 流量。
我试过的配置:
config :my_app, MyApp.Endpoint,
http: [port: "[::]:4000"]
堆栈跟踪(看起来 Phoenix 只需要一个整数端口):
** (Mix) Could not start application my_app: MyApp.start(:normal, []) returned an error: shutdown: failed to start child: MyApp.Endpoint
** (EXIT) shutdown: failed to start child: Phoenix.Endpoint.Server
** (EXIT) an exception was raised:
** (ArgumentError) argument error
:erlang.binary_to_integer("[::]:4000")
(phoenix) lib/phoenix/endpoint/server.ex:32: Phoenix.Endpoint.Server.to_port/1
(phoenix) lib/phoenix/endpoint/server.ex:28: Phoenix.Endpoint.Server.default/3
(phoenix) lib/phoenix/endpoint/server.ex:17: anonymous fn/5 in Phoenix.Endpoint.Server.init/1
(elixir) lib/enum.ex:1623: Enum."-reduce/3-lists^foldl/2-0-"/3
(phoenix) lib/phoenix/endpoint/server.ex:15: Phoenix.Endpoint.Server.init/1
(stdlib) supervisor.erl:294: :supervisor.init/1
(stdlib) gen_server.erl:328: :gen_server.init_it/6
(stdlib) proc_lib.erl:247: :proc_lib.init_p_do_apply/3
这也是凤凰{:phoenix, "~> 1.2.0"} 和牛仔{:cowboy, "~> 1.0"}
【问题讨论】:
-
您尝试过类似
[::]:4000的方法吗?见RFC 5952, Section 6, Notes on Combining IPv6 Addresses with Port Numbers。 -
感谢您的建议,但它无法解析整数。我将用更多信息更新问题,包括堆栈跟踪。
-
首先,应用程序必须支持 IPv6。看来这个应用程序没有。联系其开发者。
标签: ipv6 phoenix-framework cowboy