【发布时间】:2020-12-31 22:38:45
【问题描述】:
我有一个健康的 k8s 集群。 kube-apiserver 正在使用端口 8443。 然后我做类似下面的事情。我也创建/编辑了一个服务并分配了一个固定的 nodePort 8443。
apiVersion: v1
kind: Service
metadata:
name: my-service
spec:
selector:
app: MyApp
ports:
- protocol: TCP
port: 80
targetPort: 9376
nodePort: 8443
集群变得无法访问。如果我运行命令kubectl get pods。它返回Unable to connect to the server: EOF
因为我需要运行 kubectl 命令来更改 nodePort。但我不能使用 kubectl。它变成了一个死循环。我有 2 个问题。
- 如何才能恢复我的 k8s 集群?
- 为什么 kube-apiserver 或其他组件不阻止我将 nodePort 更改为 8443?表明端口 8443 已在使用中。
【问题讨论】:
标签: kubernetes kube-apiserver service-node-port-range