【问题标题】:Reuse the authentication of the user against LDAP in ActiveMQ Artemis在 ActiveMQ Artemis 中重用用户对 LDAP 的身份验证
【发布时间】:2019-04-25 04:05:43
【问题描述】:

LDAP 身份验证是在 ActiveMQ Artemis(2.6.1 -Redhat AMQ7.2) 环境中配置的,但我注意到用户身份验证经常针对 LDAP 服务器进行。即使没有收到任何消息,似乎也在进行身份验证。

尝试增加security-invalidation-interval,但没有考虑到这一点。

我通过打开日志注意到了这种行为。

【问题讨论】:

    标签: activemq-artemis amq


    【解决方案1】:

    security-invalidation-interval 适用于授权,但不适用于身份验证。身份验证始终命中提供帐户信息的任何内容(在本例中为 LDAP)。

    【讨论】:

    • 明白了..我们注意到以下故障。有时它是因为打开的文件太多或 Socket 连接关闭,并怀疑它可能是由于频繁的连接。 AMQ224084:无法打开上下文:javax.naming.CommunicationException:简单绑定失败
    • Artemis 2.6.3 中为 LDAPLoginModule 添加了对连接池的支持。见issues.apache.org/jira/browse/ARTEMIS-1971。因此,如果由于 LDAP 连接过多而导致文件句柄用完,那么您应该能够升级并解决该问题。
    猜你喜欢
    • 2018-09-03
    • 2022-11-30
    • 2020-07-07
    • 2011-06-18
    • 2012-07-18
    • 1970-01-01
    • 1970-01-01
    • 2019-03-12
    • 1970-01-01
    相关资源
    最近更新 更多