【问题标题】:Failed to start wso2 API Manager v2.0.0 on centos 7.0在 centos 7.0 上启动 wso2 API Manager v2.0.0 失败
【发布时间】:2016-08-15 01:51:11
【问题描述】:

我正在尝试 WSO2 API Manager 2.0,但无法启动服务器。你愿意伸出援手吗?非常感谢迈克尔

以下是版本信息。

[wso2@srv11 bin]$ ./wso2server.sh --version

WSO2 API Manager v2.0.0  
WSO2 Carbon Framework v4.4.7

但是当我使用“wso2server.sh --start”命令启动 API Manager 时,我在 wso2carbon.log 中发现了以下错误信息。

ID: [-1234] [] [2016-08-15 09:48:32,824]  INFO {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager} -  Initialised PLAIN SASL provider successfully {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager}
TID: [-1234] [] [2016-08-15 09:48:32,825]  INFO {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager} -  Additional SASL providers successfully registered. {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager}
TID: [-1234] [] [2016-08-15 09:48:32,825]  INFO {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager} -  Registering UserManagementMBean {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager}
TID: [-1] [] [2016-08-15 09:48:35,634]  WARN {java.util.prefs.FileSystemPreferences} -  Could not lock System prefs. Unix error code 32577. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:48:35,635]  WARN {java.util.prefs.FileSystemPreferences} -  Couldn't flush system prefs: java.util.prefs.BackingStoreException: Couldn't get file lock. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:48:52,850]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever} -  Failed retrieving throttling data from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever}
TID: [-1] [] [2016-08-15 09:48:52,862]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} -  Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}
TID: [-1] [] [2016-08-15 09:48:53,073]  WARN {org.wso2.carbon.application.deployer.internal.AppDeployerServiceComponent} -  Waiting for required OSGi services: org.wso2.carbon.application.deployer.synapse.service.SynapseAppDeployerService, {org.wso2.carbon.application.deployer.internal.AppDeployerServiceComponent}
TID: [-1] [] [2016-08-15 09:48:53,092]  WARN {org.wso2.carbon.core.internal.StartupFinalizerServiceComponent} -  Waiting for required OSGi services: org.wso2.carbon.application.deployer.service.CappDeploymentService,org.wso2.carbon.server.admin.common.IServerAdmin,org.wso2.carbon.throttling.agent.ThrottlingAgent, {org.wso2.carbon.core.internal.StartupFinalizerServiceComponent}
TID: [-1] [] [2016-08-15 09:49:05,628]  WARN {java.util.prefs.FileSystemPreferences} -  Could not lock System prefs. Unix error code 32577. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:49:05,628]  WARN {java.util.prefs.FileSystemPreferences} -  Couldn't flush system prefs: java.util.prefs.BackingStoreException: Couldn't get file lock. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:49:07,854]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever} -  Failed retrieving throttling data from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever}
TID: [-1] [] [2016-08-15 09:49:07,865]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} -  Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}
TID: [-1] [] [2016-08-15 09:49:24,583]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever} -  Failed retrieving throttling data from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever}
TID: [-1] [] [2016-08-15 09:49:24,593]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} -  Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}

【问题讨论】:

  • 由于 jdk 问题,我见过类似的问题。例如,当您安装了 2 个 JDK,并且没有正确给出 bin 和 HOME 的路径等时。您能检查一下吗?你是什​​么JDK?

标签: wso2 wso2-am


【解决方案1】:

由于 Java Preferences 子系统无法写入目录 /etc/.java/.systemPrefs,可能会出现此警告。您能否验证目录 /etc/.java/.systemPrefs 是否存在于您的系统中?如果存在,它对运行 JVM 实例的用户是否可写?如果不是,请提供权限并重新启动 APIM。

如果上述方法不起作用,您也可以尝试以下解决方法。

1) 在运行 JVM 的用户可以访问的地方创建一个目录,并具有以下子结构。 /.java/.systemPrefs

2) 使用 Java 选项 -Djava.util.prefs.systemRoot=<CREATED_DIR>/.java 启动 WSO2 APIM 服务器

【讨论】:

    【解决方案2】:

    关于阻塞条件异常

    TID: [-1] [] [2016-08-19 17:33:32,455]  WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} -  Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}
    

    这仅在集群部署 [x1 发布者、x1 存储、x1 网关管理器、x2 网关工作者] 时出现。独立设置不会出现此问题。

    我已尝试设置流量管理器 (tm) 节点并将网关和发布者节点指向 tm 节点 (https://docs.wso2.com/display/CLUSTER44x/Clustering+API+Manager+2.0.0),但这并不能解决问题。

    我假设,在应用 java 系统首选项修复后,您仍然遇到阻塞条件警告,但不再遇到 Unix 文件锁定异常?

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2023-04-04
      • 1970-01-01
      • 2017-07-12
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2015-06-02
      • 1970-01-01
      相关资源
      最近更新 更多