【发布时间】:2016-08-15 01:51:11
【问题描述】:
我正在尝试 WSO2 API Manager 2.0,但无法启动服务器。你愿意伸出援手吗?非常感谢迈克尔
以下是版本信息。
[wso2@srv11 bin]$ ./wso2server.sh --version
WSO2 API Manager v2.0.0
WSO2 Carbon Framework v4.4.7
但是当我使用“wso2server.sh --start”命令启动 API Manager 时,我在 wso2carbon.log 中发现了以下错误信息。
ID: [-1234] [] [2016-08-15 09:48:32,824] INFO {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager} - Initialised PLAIN SASL provider successfully {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager}
TID: [-1234] [] [2016-08-15 09:48:32,825] INFO {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager} - Additional SASL providers successfully registered. {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager}
TID: [-1234] [] [2016-08-15 09:48:32,825] INFO {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager} - Registering UserManagementMBean {org.wso2.andes.server.security.auth.manager.PrincipalDatabaseAuthenticationManager}
TID: [-1] [] [2016-08-15 09:48:35,634] WARN {java.util.prefs.FileSystemPreferences} - Could not lock System prefs. Unix error code 32577. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:48:35,635] WARN {java.util.prefs.FileSystemPreferences} - Couldn't flush system prefs: java.util.prefs.BackingStoreException: Couldn't get file lock. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:48:52,850] WARN {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever} - Failed retrieving throttling data from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever}
TID: [-1] [] [2016-08-15 09:48:52,862] WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} - Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}
TID: [-1] [] [2016-08-15 09:48:53,073] WARN {org.wso2.carbon.application.deployer.internal.AppDeployerServiceComponent} - Waiting for required OSGi services: org.wso2.carbon.application.deployer.synapse.service.SynapseAppDeployerService, {org.wso2.carbon.application.deployer.internal.AppDeployerServiceComponent}
TID: [-1] [] [2016-08-15 09:48:53,092] WARN {org.wso2.carbon.core.internal.StartupFinalizerServiceComponent} - Waiting for required OSGi services: org.wso2.carbon.application.deployer.service.CappDeploymentService,org.wso2.carbon.server.admin.common.IServerAdmin,org.wso2.carbon.throttling.agent.ThrottlingAgent, {org.wso2.carbon.core.internal.StartupFinalizerServiceComponent}
TID: [-1] [] [2016-08-15 09:49:05,628] WARN {java.util.prefs.FileSystemPreferences} - Could not lock System prefs. Unix error code 32577. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:49:05,628] WARN {java.util.prefs.FileSystemPreferences} - Couldn't flush system prefs: java.util.prefs.BackingStoreException: Couldn't get file lock. {java.util.prefs.FileSystemPreferences}
TID: [-1] [] [2016-08-15 09:49:07,854] WARN {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever} - Failed retrieving throttling data from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever}
TID: [-1] [] [2016-08-15 09:49:07,865] WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} - Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}
TID: [-1] [] [2016-08-15 09:49:24,583] WARN {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever} - Failed retrieving throttling data from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.KeyTemplateRetriever}
TID: [-1] [] [2016-08-15 09:49:24,593] WARN {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever} - Failed retrieving Blocking Conditions from remote endpoint: Connection refused. Retrying after 15 seconds... {org.wso2.carbon.apimgt.gateway.throttling.util.BlockingConditionRetriever}
【问题讨论】:
-
由于 jdk 问题,我见过类似的问题。例如,当您安装了 2 个 JDK,并且没有正确给出 bin 和 HOME 的路径等时。您能检查一下吗?你是什么JDK?