【发布时间】:2015-09-09 09:06:43
【问题描述】:
首先:我是数据库方面的新手。
我正在将 postgreSQL 与 pgAdmin III 一起使用,直到几天前它都运行良好:几天前,当我不处理它时,我在 Windows 的“后台进程”中看到几个相同的 postgreSQL 程序( ?) 正在运行,我决定停止它们,因为当时我没有使用它们。错误:现在,当我尝试连接到服务器(在本地主机上)时,我收到错误消息:
“服务器不听”
服务器不接受连接:连接库报告 无法连接到服务器:连接被拒绝 (0x0000274D/10061) 服务器是否在主机“localhost”(::1) 上运行并接受端口 5432 上的 TCP/IP 连接?无法连接到服务器:连接被拒绝 (0x0000274D/10061) 服务器是否在主机“localhost”(127.0.0.1) 上运行并接受端口 5432 上的 TCP/IP 连接?
我已经查看了 stackoverflow 上的类似主题,查看了 listen_address 文件、postgresql.conf 和 pg_hba.conf 文件,但一切似乎都是“正常的”(根据我在这些主题中读到的内容)。
我发布这个是因为......好吧,我没有找到任何其他人做我所做的事情(停止后台进程,然后无法重新连接)。
【问题讨论】:
-
您确实重新启动了 Postgres 服务,是吗? (顺便说一句:即使数据库空闲,也有多个 postgres 进程是正常的,参见例如:这里:postgresql.org/docs/current/static/monitoring-ps.html)。
-
嗯...由于我不记得我第一次连接到服务器时做了什么,在搜索了一下如何重新启动它(徒劳无功)之后,我认为pgAdmin自动启动当我尝试连接时...显然不是这样?
-
不,pgAdmin 不启动任何服务器,它只是连接到它们。在默认安装中,Postgres 注册为 Windows 服务。所以你需要从Windows控制面板启动服务。
-
我试图启动 postgres 服务(在命令行中,因为我在控制面板中找不到它 - 没有发生错误,所以显然它有效),但我看不到它在后台(或前台)进程中,我仍然无法连接。
-
technet.microsoft.com/en-us/library/cc736564%28v=ws.10%29.aspx 或 wikihow.com/Start-Services-in-Windows 那么你是如何从命令行“启动”Postgres 的呢?
标签: postgresql