【问题标题】:publish biztalk service in seperate biztalk server Error在单独的 biztalk 服务器中发布 biztalk 服务错误
【发布时间】:2014-06-03 14:20:19
【问题描述】:

我是 biztalk 的新手

我创建了双向端口,并将我的 biztalk 项目作为 biztalk 服务发布在我的本地机器上。
然后我创建了小客户端应用程序并通过已发布的 biztalk 服务访问 Biztalk 应用程序。成功发送架构并收到响应。但是对于同一个应用程序,我在单独的服务器中创建了另一个 Web 服务,它有 biztalk。

我希望 biztalk 应用程序保持原样,并从单独的服务器 biztalk 服务访问该 biztalk 应用程序。

当我使用单独的服务器 web 服务并尝试调用 web 方法时,它说:

System.Web.Services.Protocols.SoapException: Internal SOAP Processing Failure

我的 Soap 传输属性页面 web asmx:

/SampleBiztalkApp_Proxy/WebService_SampleBiztalkApp.asmx

我的肥皂传输属性页面公共地址:

{RemoteMechineName}/SampleBiztalkApp_ProxyGID /SampleBiztalkApp_SampleOrchestration_PortRR.asmx

还有其他配置可以做到这一点吗?
如果您对在单独的机器上发布 biztalk 服务有任何想法。
谢谢

【问题讨论】:

    标签: biztalk


    【解决方案1】:

    BizTalk Server 也必须在另一台机器上安装和配置。这是因为接收位置在 IIS 内的隔离主机中运行,但它仍然是 BizTalk。

    【讨论】:

    • 感谢您的回答,Biztalk Server 也安装并配置了另一台机器,但是我的 biztalk 应用程序在我的本地服务器上,有没有地方可以将单独机器上的托管 Web 服务与我的本地 biztalk 绑定申请?
    • 几个查询以进行澄清。 1. 远程服务器是否也是同一个 BizTalk Group 的一部分 2. 您如何托管远程 Web 服务?您是否在使用 WCF Web 服务发布向导?
    • 两台机器必须在同一个 BizTalk Server 组中,因此当您设置第二台时,您应该已加入现有组。这样,它们共享相同的 MessageBox,并且隔离主机 (IIS) 接收到的任何消息都可以被另一个上的编排或发送端口接收。这都是通过 MessageBox 完成的。
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2019-01-04
    • 1970-01-01
    • 2011-03-28
    • 1970-01-01
    • 2010-12-25
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多