【问题标题】:Unable to access GCP service after gke upgradegke升级后无法访问GCP服务
【发布时间】:2020-06-22 10:57:03
【问题描述】:

5月中旬自动升级。

1.14.10-gke.27 → 1.14.10-gke.36

https://cloud.google.com/kubernetes-engine/docs/release-notes?_ga=2.196679278.-315187236.1572486593#may_13_2020

之后出现 Memorystore(Redis)连接错误和 crul6 错误。

严重错误

cURL error 6: Could not resolve host: www.googleapis.com (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

此问题偶尔会发生,并非总是如此。 升级前它运行良好。

  • 不使用基于角色的访问控制
  • 工作负载标识未使用

请指教。

【问题讨论】:

  • 该错误意味着您的 DNS PODS 可能不太稳定。你在使用抢占式节点吗?另外,您能否验证一下 DNS PODS 是否已启动并运行而无需重新启动?
  • 你能分享整个错误信息吗?您是否尝试过提到的步骤here?。 /etc/hosts 文件是否包含正确的主机名?
  • @ArmandoCuevas 感谢您的评论。该节点已启用抢占式。当我运行可用性策略测试时,我能够重现 redis 连接错误和 curl6 错误。 gcloud compute instances simulate-maintenance-event <instance name> --zone <zone> 让我们禁用伪装,看看会发生什么。我想选择你的评论作为最佳答案,所以请重写它作为答案。

标签: networking google-cloud-platform


【解决方案1】:

关闭一次。 可能不是 gke 版本问题。

原因是该节点是一个可抢占的节点。 很有可能。

当我运行 Pretentive Node 的重启测试时,我能够重现错误。

gcloud compute instances simulate-maintenance-event <instance name> --zone <zone>

【讨论】:

    猜你喜欢
    • 2017-06-26
    • 1970-01-01
    • 2017-10-30
    • 2017-03-17
    • 2020-11-13
    • 2019-12-13
    • 2018-11-29
    • 1970-01-01
    • 2018-01-27
    相关资源
    最近更新 更多