【问题标题】:Running tests on browserstack throws "Cannot read property 'capabilities' of null"在 browserstack 上运行测试会抛出“无法读取 null 的属性‘功能’”
【发布时间】:2019-06-06 13:37:34
【问题描述】:

我正在使用 wdioV5 和 browserstack 运行测试,但出现以下错误:

ERROR @wdio/local-runner: Failed launching test session: TypeError: Cannot read property 'capabilities' of null

我试图检查调试日志,但无法弄清楚背后的原因,有没有人遇到过类似的问题?

调试输出:

[0-0] 2019-06-06T13:34:00.454Z INFO webdriver: Retrying 3/3
[0-0] 2019-06-06T13:34:00.455Z INFO webdriver: [POST] https://hub-cloud.browserstack.com:443/session
[0-0] 2019-06-06T13:34:00.455Z INFO webdriver: DATA { capabilities: 
   { alwaysMatch: 
      { os: 'Windows',
        os_version: '10',
        browser: 'Chrome',
        browser_version: '73.0',
        'browserstack.local': true },
     firstMatch: [ {} ] },
  desiredCapabilities: 
   { os: 'Windows',
     os_version: '10',
     browser: 'Chrome',
     browser_version: '73.0',
     'browserstack.local': true } }
[0-0] 2019-06-06T13:34:00.480Z DEBUG webdriver: request failed due to status 13
[0-0] 2019-06-06T13:34:00.481Z ERROR webdriver: Request failed due to Error: Session not started or terminated

如果它有助于重现,我的配置是:

 path: '/',
  specs: [ './specs/**/*.js' ],
  exclude: [],
  maxInstances: 10,
  capabilities: 
   [ { os: 'Windows',
       os_version: '10',
       browser: 'Chrome',
       browser_version: '73.0' } ],
  logLevel: 'trace',
  bail: 0,
  baseUrl: 'http://localhost:8000',
  waitforTimeout: 10000,
  connectionRetryTimeout: 90000,
  connectionRetryCount: 3,
  services: [ 'browserstack' ],
  framework: 'mocha',
  reporters: [ 'spec' ],
  mochaOpts: { timeout: 60000 },
  before: [Function: before],
  user: 'xxx',
  key: 'xxx',
  browserstackLocal: true,
  onPrepare: [Function: onPrepare],
  onComplete: [Function: onComplete] }

【问题讨论】:

    标签: selenium webdriver-io browserstack


    【解决方案1】:

    想通了...由于某种原因,在wdio.conf.js 中有这个选项会抛出上面的错误消息,当我删除它的那一刻,它就起作用了,这很疯狂:

    path: '/'

    【讨论】:

    • 如果您使用的是浏览器堆栈,则更改路径会弄乱命令发送到的位置。发生这种事情并不太生气。
    • 如果路径为空path: '' 它也会失败...这就是为什么我认为它根本没有使用...
    • 默认路径值为/wd/hub,附加到您的主机值(默认为http://localhost:4444,完全变为http://localhost:4444/wd/hub)。如果你设置path: '',它不会使用默认值,而只是http://localhost:4444。
    猜你喜欢
    • 2015-12-17
    • 1970-01-01
    • 2021-04-07
    • 2019-08-09
    • 2014-10-31
    • 2021-01-13
    • 1970-01-01
    • 1970-01-01
    • 2017-10-29
    相关资源
    最近更新 更多