【问题标题】:nagios nrpe-server not working on Docker for Windowsnagios nrpe-server 无法在 Docker for Windows 上运行
【发布时间】:2018-07-11 16:41:19
【问题描述】:

我正在尝试使用 nrpe 部署一个容器。这是我的docker-compose.yml 文件:

nrpe-server:
    image: binfalse/nrpe-server:full
    container_name: dr_nrpe_server
    ports:
        - "5666:5666"
    volumes:
        - $nrpe_cfg_volume
        - $nrpe_plugins_volume
    environment:
        SSL: "no"
        PORT: 5666
        ALLOWEDHOSTS: "192.168.1.34"
    logging:
        driver: syslog
        options:
            tag: docker/nrpe-server

我正在尝试在我的 Windows 10 Bash (Ubuntu) 上执行 docker-compose up,但出现以下错误:

Creating dr_nrpe_server ... error                                                                                               

ERROR: for dr_nrpe_server  Cannot start service nrpe-server: failed to initialize logging driver: Unix syslog delivery error    

ERROR: for nrpe-server  Cannot start service nrpe-server: failed to initialize logging driver: Unix syslog delivery error       
ERROR: Encountered errors while bringing up the project.         

有什么想法吗?

【问题讨论】:

    标签: docker docker-compose nagios nrpe


    【解决方案1】:

    试试这个 docker-compose 的定义:

    nrpe-server:
        image: binfalse/nrpe-server:full
        container_name: dr_nrpe_server
        ports:
            - "5666:5666"
        volumes:
            - $nrpe_cfg_volume
            - $nrpe_plugins_volume
        environment:
            SSL: "no"
            PORT: 5666
            ALLOWEDHOSTS: "192.168.1.34"
        logging:
            options:
                tag: docker/nrpe-server
    

    我删除了记录驱动程序的行。您的 Docker 将使用您的默认设置。

    【讨论】:

      猜你喜欢
      • 2020-07-09
      • 1970-01-01
      • 2019-10-08
      • 1970-01-01
      • 2022-08-10
      • 1970-01-01
      • 1970-01-01
      • 2021-10-10
      • 1970-01-01
      相关资源
      最近更新 更多