【问题标题】:elasticsearch default credentialselasticsearch 默认凭据
【发布时间】:2020-02-28 08:45:47
【问题描述】:

我发现 ES 的默认凭据是 elastic:changeme 但它对我不起作用!我错过了什么吗? 错误:

{
"error": {
    "root_cause": [
        {
            "type": "security_exception",
            "reason": "failed to authenticate user [elastic]",
            "header": {
                "WWW-Authenticate": "Basic realm=\"security\" charset=\"UTF-8\""
            }
        }
    ],
    "type": "security_exception",
    "reason": "failed to authenticate user [elastic]",
    "header": {
        "WWW-Authenticate": "Basic realm=\"security\" charset=\"UTF-8\""
      }
   },
  "status": 401
}

【问题讨论】:

  • 可以添加弹性查询吗,正在执行
  • 任何请求...我也在 localhost:9200 上的浏览​​器上尝试这些
  • 如果你使用浏览器尝试elastic:changeme@localhost:9200,如果在 curl -XPUT -u elastic:changeme 'localhost:9200' -H 'Content-Type: application/json' -d'跨度>
  • 没有用!!

标签: elasticsearch elasticsearch-x-pack


【解决方案1】:

我找到了解决办法:

只需在 cmd 上运行命令 bin/elasticsearch-setup-passwords auto -u "http://localhost:9200",密码就会重新生成并打印在控制台中。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2012-01-25
    • 2017-05-21
    • 1970-01-01
    • 2018-02-06
    • 2011-01-29
    • 1970-01-01
    • 2017-05-19
    • 2018-04-01
    相关资源
    最近更新 更多