【发布时间】:2020-12-04 18:58:40
【问题描述】:
我已在我的应用程序 Docker 映像中捆绑了 JProfiler 12 代理。 JVM 开头为:
-agentpath:/deployment/jprofiler12/bin/linux-x64/libjprofilerti.so=port=8849,nowait
当我的应用程序启动时,我看到以下错误消息:
#################################################################
JVMSHRC226E Error opening shared class cache file
JVMSHRC336E Port layer error code = -102
JVMSHRC337E Platform error message: Permission denied
JVMSHRC840E Failed to start up the shared cache.
JVMSHRC686I Failed to startup shared class cache. Continue without using it as -Xshareclasses:nonfatal is specified
JProfiler> Protocol version 64
JProfiler> Thread status info workaround enabled.
JProfiler> OpenJ9 JVMTI version 1.1 detected.
JProfiler> Java 11 detected.
JProfiler> Don't wait for frontend to connect.
JProfiler> 64-bit library
JProfiler> Could not locate the config file.
JProfiler> Please specify config=[config filename].
JProfiler> If you are running JProfiler's frontend on a different
JProfiler> machine you have to copy the file jprofiler_config.xml to this
JProfiler> computer. The file is located in $HOME/.jprofiler12 or
JProfiler> in C:\Users\[username]\.jprofiler12.
我有几个问题,我在启动帮助中找不到相关文档: https://www.ej-technologies.com/resources/jprofiler/v/12.0/help/doc/main/profiling.html
是否有可以下载示例 jprofiler_config.xml 文件的位置? 任何人都会有发送 config=[config filename] 的示例吗?
【问题讨论】:
标签: jprofiler