【问题标题】:Visual Studio Development Server (2010) and NTLM authorizationVisual Studio Development Server (2010) 和 NTLM 授权
【发布时间】:2011-08-09 07:53:04
【问题描述】:

我正在使用 Visual Studio Development Server (Visual Basic 2010),它工作正常。现在我启用了 NTLM 授权,因为我想使用不同的用户帐户测试网站。现在,当我尝试访问该网站时,我总是收到以下错误页面:

“/”应用程序中的服务器错误。

HTTP 错误 403 - 禁止。


版本信息:ASP.NET Development Server 10.0.0.0

我正在使用一个测试帐户,它是我们域中的普通用户。我已经将我的项目文件夹中的访问权限设置为该用户的完全访问权限,但这没有帮助。还有什么想法吗? 谢谢!

【问题讨论】:

    标签: asp.net vb.net visual-studio-2010 authentication ntlm


    【解决方案1】:

    另一个不需要以管理员身份运行 VS 或设置本地 IIS 的选项是确保 Visual Studio 2010 在 Service Pack 1 上,即使用 IIS Express,可在此处获得:

    http://www.microsoft.com/download/en/details.aspx?id=1038

    这是在用户模式下运行的 IIS 版本,可以处理身份验证、向远程主机提供请求等操作。简而言之,您拥有完整的请求管道,就像在完整的 IIS 中一样。安装后,当您右键单击 Web 项目时,将有一个新的菜单选项“使用 IIS Express”。这会将项目配置为使用 IIS express 并为其设置绑定。

    来自 ScottGu 的更多信息: http://weblogs.asp.net/scottgu/archive/2010/06/28/introducing-iis-express.aspx

    【讨论】:

      【解决方案2】:

      我认为这是因为工作室开发服务器非常差。我的意思是它没有像通常的 iis 那样的所有功能。所以我做了解决方法: (当然你应该在你的compure上安装iis服务器。我在win 7上使用iis 7)

      1. 在程序和功能中 -> 打开或关闭 Windows 功能的选择 互联网信息服务 -> 万维网服务 -> 安全 -> 请求过滤
      2. 在 iis 创建新站点比在身份验证设置中启用 windows 身份验证和禁用匿名身份验证
      3. 在项目属性中以管理员身份启动工作室 -> web 选择使用您在上面创建的本地 iis 服务器选择服务器按创建虚拟目录
      4. (可选)在 Web 配置中添加 这到 system.web 部分

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2010-11-29
        • 1970-01-01
        • 2011-03-25
        • 1970-01-01
        • 2013-06-06
        相关资源
        最近更新 更多