【问题标题】:Unable to connect to SQL Server using IP address无法使用 IP 地址连接到 SQL Server
【发布时间】:2015-09-19 14:16:28
【问题描述】:

我无法(使用我的 ASP.NET Web 表单应用程序或 SSMS)连接到具有公共 IP 的数据库服务器。我使用远程桌面协议成功连接到该服务器,但我机器上的 SSMS 无法连接到该服务器。我尝试了以下事情:

  1. 为端口 1433 添加了入站防火墙规则。
  2. 在 SQL Server 配置管理器中,我添加了我的公共 IP 地址:

我不知道接下来该尝试什么。请告诉我还有什么可能导致这种情况?

此外,SSMS 有时会显示Network path not found,有时会显示Server didn't reponded in time.

【问题讨论】:

  • 您可以验证是否可以使用 telnet 在指定端口上连接到该服务器。
  • @Luc Telnet 给了我这个错误:A connection attempt failed because the connected party did not properly respond after a period of time.。但是我的应用程序在我的浏览器中使用该 IP 打开。我尝试连接到<IP>:1433
  • 如果 telnet 打不开连接,则问题与网络有关,进出绑定防火墙规则如此。您可以使用 wireshark 来查看是否可以为您提供更多信息。它可能很有用,但它非常受欢迎

标签: .net sql-server database sql-server-2012 ssms


【解决方案1】:

我遇到了同样的问题,因为我的工作计算机连接到一个大型网络,计算机无法互相看到。最奇怪的部分是我可以在 Windows 资源管理器中看到我大楼中的其他计算机。

无论如何,我所做的就是尝试 UTP,即端口 1434;设置 SQL 登录凭据;更改端口设置后重新启动服务(这很重要);您截取的页面的最底部包含一个通用的 TCP 动态端口和 TCP 端口设置,我已经更改了这些。在 SSMS 中右键单击数据库并说“允许远程连接”。这里还可以设置超时等

对我来说真正奇怪的是另一台计算机可以看到数据库,但无法连接。

如果您已经尝试了我在上面尝试过的所有方法,那么您就和我一样。我也在使用 SQL-2012,但在 Windows 7 企业版上。我会测试更多的东西,但我不在工作。另外我本来只是发表评论,但我不能):

【讨论】:

  • 另外,看看这个。看来其他人已经成功了!他们就是希望!! Stack, enable remote SQL
  • 我尝试了您在该链接上建议的所有设置。但没有任何效果。
  • 只是想我会提供所有我听说过的东西。我有和你一样的问题。我将尝试通过 Visual Studio 远程连接,并尝试共享日志和数据库文件,以便另一台计算机可以访问数据并写入日志,即使它并不能真正解决问题。我也很好奇这是否与微软的 SQL 许可有关,所有接触数据库的人都必须拥有唯一的许可。
  • 我解决了。检查我的答案。如果您能找出原因,请告诉我。
  • 我发现我所在的域阻止了端口流量,但仅在某些情况下。这很奇怪,因为端口查询会起作用。但是,我的部门并没有与 IT 斗争,而是选择了 amazon redshift(它并不像它所说的那么快,即使是带有 SQL 索引的外部硬盘驱动器的 apc 也更快)。只是我的 0.02 美元。
【解决方案2】:

最后,我自己解决了。我不知道为什么,但没有应用防火墙规则。但后来我发现我的谷歌云控制台也提供了添加防火墙规则的选项。因此,我没有将规则直接添加到 Windows 防火墙,而是将其添加到 Google Cloud Firewall 设置中。它就像一个魅力。不知道为什么这解决了我的问题。如果有人能解释原因,那就太好了。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2013-07-18
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2011-06-06
    相关资源
    最近更新 更多