【问题标题】:MS Reporting Services - Slow ReportsMS 报告服务 - 慢速报告
【发布时间】:2012-01-13 02:01:57
【问题描述】:

我创建了一个匿名的 SSRS 网络包装器,它已经运行了几个月而没有出现错误。最近,我们发布了年终版本,据我所知,生产版本的一份报告存在问题。开发和测试环境生成的报告没有错误,它只是生产失败的地方。我们已经开始解决问题,结果如下:

存储过程的执行时间有时以秒为单位,有时超过 20 分钟。

上述方法也适用于使用报表管理器呈现报表。

一旦进入 SSRS 包装器,它就会完全失败。即使考虑到存储过程执行的时间量存在波动,在我看来,即使我将包装器设置为没有超时,存储过程仍然可能是罪魁祸首。

至于报表服务器,我不是 DBA,所以我不熟悉 rs.config 文件。另外,我阅读了一些关于使用 IIS 6 以某种方式设置的设置。根据 DBA 的说法,它不会从 IIS 6 中运行。同样,这是我不熟悉的。

我还有一个问题是参数嗅探。传入三个参数,一个是在 RB 3.0 中设置为 Text 的 City,在 SQL 中设置为 Varchar,在 RB 3.0 中设置为 int 的月份和年份,在 sql 中设置为 integer。

我知道第一次出现此错误是因为服务器已重置并且报告生成时没有错误。从那时起,他们已经能够稳定服务器,但现在报告没有呈现。任何有故障排除建议的人请前来救援。

【问题讨论】:

    标签: reporting-services reportmanager


    【解决方案1】:

    我有一个负面的。抱歉这个不好的问题。无论如何,问题是存储过程。 DBA 告诉我他必须重置统计信息。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2019-01-08
      • 1970-01-01
      • 2010-09-26
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多