【问题标题】:SSIS Packages unable to load due to XML issues由于 XML 问题,SSIS 包无法加载
【发布时间】:2017-10-23 11:51:40
【问题描述】:

我创建了一个 SSIS 包,它从本地计算机收集数据并将其作为新表存储到新服务器中。当我调用它时,包运行成功,但 SQL Server 代理无法运行它。我授予服务器访问本地计算机的权限,但它仍然拒绝。我得到的建议之一是我需要让服务器访问我与服务器共享的包,但我仍然得到相同的结果。我该如何解决这个问题?请按照分步说明进行回答,因为这是我尝试安排的第一个 SSIS 包。

【问题讨论】:

  • 能否提供您当前的 shedule 配置的屏幕截图?
  • 如何在此处添加图片?
  • “{}”右侧应该有一个图标,显示类似山的东西。点击它,系统会提示您拖放图片。
  • 完成我添加了屏幕截图。那里的时间表只是为了测试
  • 请确认并截图您的 Job / Jobstep 配置

标签: sql-server ssis sql-server-2017


【解决方案1】:

本地机器意味着运行进程的本地机器。当您在桌面上运行该软件包时,它就是本地计算机。当您的服务器尝试运行该软件包时,该服务器就是本地计算机。

服务器将在运行时解析基于驱动器的文件路径,要求服务器在其 C:\Users\DitsheOO..... 路径中查找包。如果该路径/包不存在,则作业\包将失败。

您需要将包发布到服务器的本地驱动器(它不会在您桌面的本地驱动器中)并更新 SQL Server 代理作业定义。

或者最好使用一个 UNC 路径(例如 \servername\servershare\folderpath...\packagepath.dtsx),任何设备都可以访问该文件夹,并获得该文件夹的权限。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2015-11-13
    • 1970-01-01
    • 1970-01-01
    • 2012-06-19
    • 1970-01-01
    • 2017-08-15
    • 1970-01-01
    • 2023-01-27
    相关资源
    最近更新 更多