【问题标题】:SQL Job step to map a network drive to a specific letter将网络驱动器映射到特定盘符的 SQL 作业步骤
【发布时间】:2015-04-23 20:55:52
【问题描述】:

我正在创建一个 SQL 作业,第一步我需要映射到网络驱动器并确保它始终映射到 Z:。问题是如果驱动器已经被映射,它会失败并显示“本地设备名称已在使用”错误,如果我手动断开驱动器,我会得到同样的错误。我希望找到一种方法来做到这一点,而不必每次都删除和重新创建地图。这可能吗?

我现在正在使用

cmd.exe /c net use z: \\drivelocation DriveAccessCode

这再次导致“设备名称已在使用中”,如果我断开驱动器,我会收到同样的错误。我希望这个不用做就可以工作

net use del z 

每次。即使有一种方法可以检查它是否已映射,如果已映射,则转到第 2 步。任何帮助都会令人惊叹。谢谢。

【问题讨论】:

    标签: cmd sql-server-2014 sql-job


    【解决方案1】:

    尝试检查驱动器是否未先映射:

    cmd.exe /c if not exist z:\* net use z: \\drivelocation DriveAccessCode

    【讨论】:

    • 这很好用,谢谢。我试过如果不存在,但我认为我包含了一个不必要的“then”。
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2010-10-08
    • 1970-01-01
    相关资源
    最近更新 更多