【问题标题】:How to start local docker pulled image (apereo/cas)?如何启动本地 docker pull image (apereo/cas)?
【发布时间】:2018-02-09 21:31:12
【问题描述】:

我尝试使用:

docker pull apereo/cas

然后我尝试了:

docker run -p 80:8080 -p 443:8443 -d --name="cas" apereo/cas

我收到以下错误:

docker: Error response from daemon: OCI runtime create failed: container_linux.go:296: starting container process caused "exec: \"cas-overlay/bin/run-cas.sh\": stat cas-overlay/bin/run-cas.sh: no such file or directory": unknown.

除了 docker 拉取镜像外,没有任何文档。

我能做些什么来解决这个问题?

https://github.com/apereo/cas-webapp-docker

【问题讨论】:

    标签: docker cas


    【解决方案1】:

    看起来有人搞砸了;当前的latest 标签是合法的。试试different pinned tagv.5.2.2 为我工作,就像这样:

    docker run -p 80:8080 -p 443:8443 -d --name="cas" apereo/cas:v5.2.2

    【讨论】:

    • 我已经使用了这个命令,但我无法访问接口或端口上的任何东西,请您告知可能是什么问题?
    • @Karan 以交互模式运行容器,看看里面发生了什么。可能由于缺少证书而无法启动,您必须初始化密钥库。见stackoverflow.com/questions/52099768/…
    猜你喜欢
    • 1970-01-01
    • 2020-04-19
    • 1970-01-01
    • 2020-06-24
    • 1970-01-01
    • 2020-11-10
    • 2020-06-22
    • 1970-01-01
    • 2021-12-22
    相关资源
    最近更新 更多