【发布时间】:2017-04-30 20:32:35
【问题描述】:
我一直在尝试将我的 Rails 应用程序从 5.1.0rc1 迁移到 5.1.0。
这是我的 gemfile:
gem 'rails', '~> 5.1.0'
gem 'mysql2', '>= 0.3.18', '< 0.5'
gem 'puma', '~> 3.0'
gem 'sass-rails', '~> 5.0'
gem 'turbolinks', '~> 5'
gem 'uglifier', '>= 1.3.0'
gem 'redis', '~> 3.3.3'
gem 'redis-rails', '~> 5.0.1'
gem 'jbuilder', '~> 2.5'
gem 'sidekiq', '~> 4.2.10'
gem 'active_model_serializers', '~> 0.10.5'
gem 'jwt', '~> 1.5.6'
gem "mini_magick", '~> 4.7.0'
gem 'rack-cors', "~> 0.4.1"
gem 'mandrill-api', "~> 1.0.53"
gem 'curb', "~> 0.9.3"
gem 'inherited_resources', '~> 1.7'
gem 'activeadmin', '~> 1.0.0'
gem 'coffee-rails', '~> 4.2.1'
gem 'therubyracer', git: 'https://github.com/cowboyd/therubyracer.git'
gem 'meta-tags', '~> 2.4.0'
gem 'slim', '~> 3.0.7'
这是我从捆绑安装中得到的:
Bundler could not find compatible versions for gem "actionpack":
In Gemfile:
active_model_serializers (~> 0.10.5) was resolved to 0.10.5, which depends on
actionpack (< 6, >= 4.1)
activeadmin (~> 1.0.0) was resolved to 1.0.0, which depends on
formtastic (~> 3.1) was resolved to 3.1.5, which depends on
actionpack (>= 3.2.13)
activeadmin (~> 1.0.0) was resolved to 1.0.0, which depends on
inherited_resources (~> 1.7) was resolved to 1.7.0, which depends on
actionpack (< 5.1, >= 3.2)
rails (~> 5.1.0) was resolved to 5.1.0, which depends on
actionpack (= 5.1.0)
rails (~> 5.1.0) was resolved to 5.1.0, which depends on
actionpack (= 5.1.0)
rails (~> 5.1.0) was resolved to 5.1.0, which depends on
actionpack (= 5.1.0)
activeadmin (~> 1.0.0) was resolved to 1.0.0, which depends on
ransack (~> 1.3) was resolved to 1.8.2, which depends on
actionpack (>= 3.0)
可能出了什么问题?
如果有帮助(但我对此表示怀疑),我会在 Docker 容器上工作。我已经删除了Gemfile.lock 以避免冲突。
【问题讨论】:
-
Rails 5.1.0 尚未发布。最新的是
5.1.0.rc2 -
好吧,我还以为是公告的原因。我的坏:)
-
什么公告?我很可能错过了,但它不会在我的机器上更新到超过 5.1.0.rc2
-
好的,有趣的是,它不会在我的机器上更新到最终版本。希望这很快就会发生
标签: ruby-on-rails gemfile ruby-on-rails-5.1