【问题标题】:5: Input/output error Error: Failure while executing; `/bin/launchctl bootstrap gui/502 and FATAL: password authentication failed for user5:输入/输出错误错误:执行失败; `/bin/launchctl bootstrap gui/502 和 FATAL:用户的密码验证失败
【发布时间】:2021-09-07 21:34:52
【问题描述】:

错误5:输入/输出错误:执行失败; /bin/launchctl bootstrap gui/502 /Users/Andrea/Library/LaunchAgents/homebrew.mxcl.postgresql.plist exited with 5 在输入命令“brew services start postgresql”时发生。

我正在尝试使用自制软件和 postgresql 创建数据库。如果我键入命令“brew services stop postgresql”然后将其启动备份,则不会发生错误。但是会在 postgresql 的初始启动时再次发生。

之后,我停止 postgresql 并使用自制软件重新启动它,我输入“createdb 'test'。出现此错误:

“错误:无法连接到数据库模板1:致命:用户“Andrea”的密码验证失败。最初我尝试主要处理密码验证,但没有运气。

以下是我采取的步骤:

  1. 我已将方法列更改为信任我的 hba_pg 文件。
  2. 我已尝试在终端中使用命令 ALTER 更改密码。
  3. 我在我的计算机上创建了一个 root 登录,我尝试访问该文件并使用 root 的密码来创建数据库。
  4. 用于更改我的用户密码的命令 chpass。

我们将不胜感激。谢谢!

【问题讨论】:

    标签: postgresql passwords homebrew


    【解决方案1】:

    这是我在 Mac 上解决的问题。

    1. 看了postgres.log cat /usr/local/var/log/postgres.log | tail -100
    2. 在我的日志中发现以下错误 FATAL: lock file "postmaster.pid" already exists
    3. 修复上述 PID 问题并重启服务器。
    rm /usr/local/var/postgres/postmaster.pid 
    brew services restart postgresql
    

    【讨论】:

    • 谢谢!这很有帮助。我在查看日志时遇到了另一个错误,它是:``` 2021-10-20 12:06:41.065 IST [50107] 致命:数据库文件与服务器 2021-10-20 12:06:41.065 IST 不兼容[50107] 详细信息:数据目录由 PostgreSQL 版本 13 初始化,与此版本 14.0 不兼容。不允许“root”执行 PostgreSQL 服务器。 ``` 所以我必须确保我安装了正确版本的 Postgres。
    • 我有同样的错误,但我的错误日志显示:不允许“root”执行 PostgreSQL 服务器。必须在非特权用户 ID 下启动服务器,以防止可能的系统安全受损。有关如何正确启动服务器的更多信息,请参阅文档。不知道为什么,因为它没有以 root 身份启动。
    • 在 M1 mac 上,此文件夹位于 /opt/homebrew/var/postgres
    【解决方案2】:

    有时这可以通过简单的运行来解决

    brew services restart postgresql
    

    而不是

    brew services start postgresql
    

    当先前的 postgres 进程未正确终止时会发生这种情况(可能是因为您在活动监视器中杀死了 psql 进程或其他原因)。重新启动似乎可以正确解锁/删除 postmaster.pid 文件,而“start”则没有。

    【讨论】:

    • 帮我解决了这个问题。谢谢!
    【解决方案3】:

    在 m1 mac 上,我遇到了同样的问题,也不得不删除 postmaster.pid 文件。对于m1 mac,文件在/opt/homebrew/var/postgres/postmaster.pid,所以我跑了

    /opt/homebrew/var/postgres/postmaster.pid
    

    我可以brew services start postgresql成功。

    【讨论】:

      【解决方案4】:

      为了建立在@gajen-sunthara 所说的基础上,我确保升级了我的 postgresql 安装:

      brew services upgrade postgresql
      

      然后删除 postmaster.pid:

      rm /usr/local/var/postgres/postmaster.pid 
      

      然后重启postgresql:

      brew services restart postgresql
      

      这应该让它重新开始:)

      【讨论】:

      • brew services upgrade postgresql 给了我一个错误,但brew upgrade postgresql 让我安装了更新版本的 postgres。只是想我会提到它。 :)
      猜你喜欢
      • 1970-01-01
      • 2021-09-18
      • 2016-08-30
      • 2019-11-18
      • 1970-01-01
      • 2016-01-25
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多