【发布时间】:2016-09-27 09:39:41
【问题描述】:
所以我从
开始brew reinstall php56 --with-apache
这很好,然后我修改了httpd.conf 以包含
LoadModule php5_module /usr/local/opt/php56/libexec/apache2/libphp5.so
但在检查phpinfo 时,它使用的是错误的 PHP 5.6.24,这是 MacOS 原生版本。 brew 版本是 5.6.26。
由于某种原因,我的 Apache2 配置被忽略 - 或者我修改了错误的文件。我改成/etc/apche2/httpd.conf的那个
这是我的previous question 的后续内容,与让 APCu 工作有关。它适用于 PHP 的 brew 版本,但不适用于原生 PHP 版本。因此,我想强制 Apache2 使用带有 APCu 的 brew 版本。
【问题讨论】:
-
你在运行发行版 apache 吗?而且,您使用的是
php-fpm吗?而且,你重启了 apache 吗? -
尝试硬连线...这就是我当前安装的方式:
LoadModule php5_module /usr/local/Cellar/php55/5.5.38/libexec/apache2/libphp5.so。不要忘记重新启动apache。我稍后会回来。 -
重启我的机器修复了!什么?!
-
那是你的 appleDogmaInAbox:因为 SIP,他们有 apachectl 完全附属于 LaunchControl ...发布另一个问题,我会为您详细说明如何使用发行版 apache(不是一个简单的问题)。
-
下次您需要更改 httpd 配置时,不要重新启动尝试到
killall httpd,LaunchControl 会立即重新启动它。