【发布时间】:2013-12-17 15:25:33
【问题描述】:
我正在尝试在 Debian 7.3(Ruby 1.9.3p194,Rails 2.3.14)上运行 Ruby/Rails 教程,但我似乎无法让服务器以任何命令行参数启动。作为 root,我在 /root 中创建了一个 rails 骨架目录,其中
# rails -d postgresql demo/inventory
我可以通过执行脚本/服务器在默认端口 3000 上启动服务器,但是给出命令行参数的任意组合(例如,-d 表示守护程序模式,-p 80 表示在端口 80 上运行)会给出错误:
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- rack/handler/-p (LoadError)
或
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- rack/handler/-d (LoadError)
任何命令行参数都被同样处理。最后的致命错误之前是一堆警告(即使我在没有参数的情况下成功地在端口 3000 上启动了服务器):
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from /root/demo/inventory/vendor/rails/railties/lib/rails/gem_dependency.rb:21.
NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It will be removed on or after 2011-11-01.
Gem::SourceIndex#initialize called from /root/demo/inventory/vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
最后一个警告重复了几次。我觉得我缺少一些包或宝石,但我不知道从哪里开始。
【问题讨论】:
标签: ruby-on-rails ruby ruby-on-rails-2