【发布时间】:2017-11-24 09:29:12
【问题描述】:
我正在使用 docker swarm 并希望使用 docker-compose 部署服务。我的服务使用了一个名为 myuser/myrepo:mytag 的自定义映像,我成功地将它部署到 Docker-Hub 到一个私有存储库。
我的 docker-compose 看起来像这样:
version: "3.3"
services:
myservice:
image: myuser/myrepo:mytag
ports:
- "8080:8080"
在执行之前,我成功拉取了镜像:docker pull myuser/myrepo:mytag
当我运行docker stack deploy -c docker-compose.yml myapp 时,我总是收到错误:"No such image: myuser/myrepo:mytag"。
有趣的是,仅使用 docker-compose up(即没有 swarm 模式)运行相同的文件,一切正常,服务启动。
我真的不明白为什么会失败?
我已经尝试用docker system prune 清理docker,然后repull我的图像,没有成功。
【问题讨论】:
标签: docker docker-compose docker-swarm docker-stack