【问题标题】:SQL Invalid ALTER TABLE optionSQL 无效的 ALTER TABLE 选项
【发布时间】:2015-06-10 18:44:49
【问题描述】:

使用以下 SQL 语句:

ALTER TABLE USERS
    ADD LAST_LOGIN DATETIME() 

我收到以下错误:

Error report -
SQL Error: ORA-01735: invalid ALTER TABLE option
01735. 00000 -  "invalid ALTER TABLE option"
*Cause:    
*Action:

我一生都无法理解为什么 SQLDeveloper 不喜欢我相当简单的 alter table 命令的初始化。

【问题讨论】:

  • 你可以试试不带括号的 DATETIME 吗?
  • 这给了我:错误报告 - SQL 错误:ORA-00902:无效数据类型 00902。00000 -“无效数据类型”*原因:*操作:
  • 您确定您的 oracle 版本具有日期时间数据类型吗?
  • 嗯,如果没有,有没有办法添加一个?如果是这种情况,我认为它会给我一个无效的数据类型错误

标签: sql oracle datetime add alter-table


【解决方案1】:

DATETIME 不是有效的列数据类型。如果您尝试添加默认值,则需要指定 DEFAULT

如果您尝试使用日期格式,请使用datetime or interval data types 之一。如果您需要存储日期和时间,标准的DATE 格式存储年、月、日、小时、分钟和秒。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2017-11-14
    • 2016-03-30
    • 1970-01-01
    • 2014-05-28
    • 1970-01-01
    相关资源
    最近更新 更多