【问题标题】:Uploading large file to EB AWS service fail with error 400 bad request将大文件上传到 EB AWS 服务失败并出现错误 400 bad request
【发布时间】:2018-10-05 20:15:19
【问题描述】:

我有一个将文件上传到 Elastic Bean AWS 服务的移动应用程序,使用 Nodjs 部署的 API,然后使用 skipperS3 的 API 将文件上传到 S3 Bucket,当我上传高达 60-100 MB 的小文件时,上传成功没有错误,当我尝试上传更大的文件时,我得到了

<html>
<head><title>400 Bad Request</title></head>
<body bgcolor="white">
<center><h1>400 Bad Request</h1></center>
<hr><center>cloudflare</center>
</body>
</html>

我相信错误与服务器有关,而不是与移动应用程序有关,知道如何找到问题吗?

请注意,我在 Amazon 上使用负载均衡器运行的实例不止一个。

【问题讨论】:

    标签: node.js amazon-web-services file-upload httprequest amazon-elastic-beanstalk


    【解决方案1】:

    如果您的 EB 环境在负载均衡器后面运行,NGINX 中有一个默认文件大小限制,将拒绝大文件。

    这可能是相关的:increasing-client-max-body-size-in-nginx-conf-on-aws-elastic-beanstalk

    【讨论】:

      猜你喜欢
      • 2022-11-29
      • 1970-01-01
      • 1970-01-01
      • 2020-12-09
      • 1970-01-01
      • 2015-11-16
      • 2021-04-11
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多