【问题标题】:Site rebuilt and IIS stopped working站点重建和 IIS 停止工作
【发布时间】:2013-07-13 03:37:09
【问题描述】:

我一直在帮助客户重建一个托管在 IIS 6 上的网站(我认为),因为他解雇了 IT 主管。 其中一项任务是更改数据库访问的所有密码,一切顺利。

鉴于此,我们必须重新编译 Web 应用程序/网站以反映这些更改(新用户/密码),我们尝试重建网站(一切正常),然后将文件放在与之前相同的文件夹中是,基本上替换了服务器上的内容。

但是现在,该网站根本无法工作,只是给出一个错误的请求,我似乎无法解决这个问题。 我以前从未使用过 IIS,所做的配置是非常基本的(几乎什么都没有),所以我似乎无法理解为什么这不起作用。

有人可以帮忙吗?

谢谢, BR

【问题讨论】:

标签: asp.net iis iis-6


【解决方案1】:

嗯,原来这个问题分为两部分导致问题。

第 1 个问题是 Web.config 文件未正确设置到生产环境,从而导致无法访问问题。 第二个原因是,由于某种原因,IIS 被设置为使用 ASP.NET v2,而网站是使用 .NET 4 构建的。虽然这不应该是一个问题,但它会导致一些其他问题。

如果有人遇到同样的问题,至少检查一下这两项是值得的,并进行 IIS 重置。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2012-06-14
    • 1970-01-01
    • 2022-07-05
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多