【问题标题】:SSRS Report Fails to Load in .net Report ApplicationSSRS 报告无法在 .net 报告应用程序中加载
【发布时间】:2013-02-27 19:17:00
【问题描述】:

我们有一个自定义的 .net 报告应用程序,它正在尝试加载稍微数据密集的 SSRS 报告。奇怪的是,当报告通过报告管理器和 Mozilla Firefox 运行时,报告运行良好并返回数据,尽管速度有点慢。 The problem is when a user attempts to load it through the Report Application in IE9, when all parameters are selected to maximize the data returned (20k rows), the report gets stuck on the Loading animation.浏览器最终死机,需要强制关闭。报表对象本身的数据集中没有指定超时时间,报表管理器中也没有指定任何超时设置。报表服务器执行日志显示 TimeDateRetrieval 和 TimeProcessing 时间,表明报表加载成功。我们认为报告应用程序上有一个设置需要调整。

我们已经将web.config文件中的httpRunTime参数配置为:

 <httpRuntime executionTimeout = “600”>

我们也尝试如下配置 ViewReport.aspx 文件

 <asp:ScriptManager ID="ScriptManager1" runat="server" AsyncPostBackTimeout="0"> </asp:ScriptManager>

有什么建议吗?

【问题讨论】:

  • 如果脚本管理器超时,您会看到加载指示器变成空白屏幕,并且 ssrs 中的日志条目表明客户端已断开连接。我不认为这是你的问题。在您的情况下,服务器似乎已停止通信。 SSRS 有一个站点范围的超时,报告有两个与呈现和查询时间相关的设置。报表有一个渲染执行超时,而报表的数据集有一个查询超时。但是,我认为如果任何 ssrs 计时条件触发了错误,您将在回发中得到该错误。
  • 您可以在 SSRS 管理器中使用您的所有参数运行报告吗?我最近不得不将旧应用程序中 ajax 脚本管理器的超时时间增加到 9 分钟。如果报表在 SSRS 中呈现没有问题,则您的应用所在的服务器与呈现报表的服务器之间可能存在通信错误。
  • 选择的参数越少,返回的数据越少,报告就会加载。我们倾向于这是一个与服务器相关的问题。看起来我们将咨询 MSFT。是时候准备好日志了:(

标签: asp.net .net reporting-services web-config ssrs-2008


【解决方案1】:

报告查看器模块中的 ASyncPostBackTimeout 属性设置似乎已更改。将其恢复为 ASyncPostBackTimeout="0" 就可以了。它确实与脚本管理器有关。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2014-03-22
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多