【发布时间】:2016-12-20 23:21:16
【问题描述】:
我发现我的图表总是失败。
我重新启动了我的服务,它工作了一会儿,然后就不再工作了。
查看我的日志,我发现了以下异常。
关于我的服务器。
Centos 6 125 内存 15 核。
我的 kibana 使用以下服务。
-logstash -弹性搜索 -kibana
在我的日志中,我有以下信息:
[2016-12-20 16:29:17,694][DEBUG][action.search.type ] [Zeitgeist] [logstash-2016.12.19][0], node[rer0mIPDRPeD7dkjrX9h5A], [P], s[STARTED]: Failed to execute [org.elasticsearch.action.search.SearchRequest@664e869f] lastShard [true]
org.elasticsearch.search.query.QueryPhaseExecutionException: [logstash-2016.12.19][0]: query[filtered((program:httpd) _all:and (syslog_severity:notice))->BooleanFilter(+QueryWrapperFilter(ConstantScore(*:*)) +cache(@timestamp:[1482268665727 TO 1482272265727]))],from[0],size[0]: Query Failed [Failed to execute main query]
at org.elasticsearch.search.query.QueryPhase.execute(QueryPhase.java:163)
at org.elasticsearch.search.SearchService.loadOrExecuteQueryPhase(SearchService.java:301)
at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:312)
at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:231)
at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:228)
at org.elasticsearch.search.action.SearchServiceTransportAction$23.run(SearchServiceTransportAction.java:559)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.OutOfMemoryError: Java heap space
问候
【问题讨论】:
标签: elasticsearch logstash kibana centos6