【问题标题】:HYperledger composer v0.19.2 network start fails with Error [lscc] executeDeployOrUpgrade -> ERRO 46e cannot get package for chaincode?HYperledger composer v0.19.2 网络启动失败并出现错误 [lscc] executeDeployOrUpgrade -> ERRO 46e 无法获取链码的包?
【发布时间】:2018-05-14 03:57:22
【问题描述】:

hscsys@ggnlabvm-decent01:~/fabric-dev-servers/fabric-scripts/hlfv11$ composer network install -c PeerAdmin7@hsc-network -a hscdb2@0.0.1.bna ✔ 安装业务网络。这可能需要一分钟... 成功安装业务网络hscdb2,版本0.0.1

hscsys@ggnlabvm-decent01:~/fabric-dev-servers/fabric-scripts/hlfv11$ composer network start --networkName hsc-network --networkVersion 0.0.1 -A admin -S adminpw -c PeerAdmin7@hsc-网络 在版本 0.0.1 启动业务网络 hsc-network

处理这些网络管理员: 用户名:管理员

✖ 开始业务网络定义。这可能需要一分钟... 错误:尝试启动业务网络时出错。错误:没有来自任何对等方的有效响应。 来自尝试的对等通信的响应是一个错误:错误:2 UNKNOWN:链码错误(状态:500,消息:无法获取链码的包(hsc-network:0.0.1)) 命令失败

Docker 对等日志: **

2018-05-14 03:14:31.481 UTC [lscc] executeDeployOrUpgrade -> ERRO 46e 无法获取链码的包(hsc-network:0.0.1)-err:open /var/hyperledger/production/chaincodes/hsc-network.0.0.1:没有这样的文件 或目录

** 2018-05-14 03:14:31.481 UTC [shim] func1 -> DEBU 46f [35f3cb07]交易完成。发送完成 2018-05-14 03:14:31.481 UTC [shim] func1 -> DEBU 470 [35f3cb07]移动状态消息已完成 2018-05-14 03:14:31.481 UTC [shim] handleMessage -> DEBU 471 [35f3cb07] 处理链码消息类型:已完成(状态:就绪) 2018-05-14 03:14:31.481 UTC [shim] func1 -> DEBU 472 [35f3cb07]发送状态消息已完成 2018-05-14 03:14:31.481 UTC [chaincode] processStream -> DEBU 473 [35f3cb07]从 shim 收到消息 COMPLETED 2018-05-14 03:14:31.481 UTC [chaincode] handleMessage -> DEBU 474 [35f3cb07]Fabric 侧处理 ChaincodeMessage 类型:在状态就绪状态下完成 2018-05-14 03:14:31.481 UTC [chaincode] handleMessage -> DEBU 475 [35f3cb076594d00463deec6952700cd3f69ea7b345676360d5d0f1511d12e31d]HandleMessage- 已完成。通知 2018-05-14 03:14:31.481 UTC [链码] 通知 -> DEBU 476 通知 Txid:35f3cb076594d00463deec6952700cd3f69ea7b345676360d5d0f1511d12e31d,channelID:composerchannel 2018-05-14 03:14:31.481 UTC [链码] 执行 -> DEBU 477 退出 2018-05-14 03:14:31.481 UTC [endorser] callChaincode -> DEBU 478 [composerchannel][35f3cb07] 退出 2018-05-14 03:14:31.481 UTC [lockbasedtxmgr] GetTxSimulationResults -> DEBU 479 模拟完成,获得模拟结果 2018-05-14 03:14:31.481 UTC [lockbasedtxmgr] 完成 -> DEBU 47a 完成交易模拟/查询执行 [35f3cb076594d00463deec6952700cd3f69ea7b345676360d5d0f1511d12e31d] 2018-05-14 03:14:31.481 UTC [背书人] 模拟提案-> DEBU 47b [composerchannel] [35f3cb07] 退出 **

2018-05-14 03:14:31.481 UTC [背书人] ProcessProposal -> ERRO 47c [composerchannel][35f3cb07]simulateProposal() 导致链码 名称:“lscc” txid 的响应状态 500:

** 35f3cb076594d00463deec6952700cd3f69ea7b345676360d5d0f1511d12e31d

【问题讨论】:

    标签: hyperledger-fabric hyperledger hyperledger-composer


    【解决方案1】:

    启动网络时,您需要指定正确的网络名称和版本。如果您查看安装命令的输出

    hscsys@ggnlabvm-decent01:~/fabric-dev-servers/fabric-scripts/hlfv11$ composer network install -c PeerAdmin7@hsc-network -a hscdb2@0.0.1.bna

    ✔ 安装业务网络。这可能需要一分钟...

    成功安装业务网络hscdb2,版本0.0.1

    最后一行显示刚刚安装的业务网络的名称和版本(hscdb2、0.0.1)。因此启动命令将是

    hscsys@ggnlabvm-decent01:~/fabric-dev-servers/fabric-scripts/hlfv11$ composer network start --networkName hscdb2 --networkVersion 0.0.1 -A admin -S adminpw -c PeerAdmin7@hsc-network

    这是您在业务网络的 package.json 中指定的名称和版本。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2019-07-27
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多