【发布时间】:2010-04-14 10:14:43
【问题描述】:
[我正试图找出我拥有another problem 的原因,而这个问题是谜题的一部分。]
我有一个 MVC 2 网站,该网站设置了路由,以便 /Customer/23/Order/47 等 URL 由各种控制器处理。我确实没有有一个匹配的规则,例如 /nosuchpage 并且在我的 Cassini 环境中,对该 URL 的请求将触发我的 Application_Error 代码,这让我可以记录错误并显示友好的响应。
但是,当我使用集成模式在 IIS7 上部署这个网站时,我的 Application_Error 没有被触发,并且 IIS 显示了它自己的 404 消息。无论我尝试了什么,都无法触发 Application_Error。
现在我在想:它没有触发的原因是因为请求没有通过我的应用程序路由吗?要么是因为我没有明确设置一个包罗万象的路由,要么是因为文件扩展名让它认为它应该使用“静态文件处理程序”(不管是什么)?
我应该期待我的 Application_Error 被调用吗?
【问题讨论】:
标签: asp.net-mvc iis-7 asp.net-mvc-routing