【问题标题】:IIS 8.5 Proxy rewrite failingIIS 8.5 代理重写失败
【发布时间】:2017-10-18 08:20:34
【问题描述】:

我是设置代理服务器的新手。在我们实际的 Web 服务器上。我们有我们的网站,在 IIS 中,它位于 wwwroot 下。然后,我在 wwwroot 之外还有 2 个其他目录,一个包含图像,一个包含文档。在我介绍代理之前,主站点有其他两个区域的虚拟目录,一切都很好。转向更复杂的设置,我删除了虚拟目录,因为这些需要通过代理重新定向。因此,基本上来自主站点的图像或文档的任何地址都需要通过代理重定向到图像或文档区域。

我在 IIS 中创建了另外 2 个网站,一个用于文档,一个用于图像,并且我已将它们的 IP 设置为与包含相同端口的主站点相同。现在转移到代理。我已经为所有站点创建了服务器场,在此处将它们称为与网络服务器上的名称相同的名称 (dns)。这为场中的每个服务器创建了默认的 ARR URL 重写规则。我在代理服务器级别编写了一个入站规则,该规则应该重定向图像,并且使用内置测试表明我将测试正确地放在一起。但是,将其放置在此处或在出站规则上没有任何区别。

我在代理上安装了 IIS 跟踪工具,并注意到在查看跟踪日志后没有命中测试。我将规则移至针对默认站点而不是服务器的 url 重写入站。现在在第 4 步的跟踪中,我可以正确地看到旧 url 已更改为我的 newURL,并且 NewUrl 是我预期的 url,太棒了!但是,当 Trace 到达第 40 步时,它会将我的新正确 url 作为输入,并在此步骤中删除新 url 的域名,从而有效地将地址恢复为原始地址。在进行初始更改的入站规则上,我检查了Stop processing of subsequent rules。

【问题讨论】:

    标签: iis proxy


    【解决方案1】:

    这些是我为图像所做的步骤,它们终于通过了。

    1. 在网络服务器上,我所有的网站都有相同的 IP 和端口号,只是主机名不同。
    2. 现在在我的本地客户端计算机上,在我的 hosts 文件中,我将主站点指向代理的 ip,但我想重定向到的其他站点将它们的 ip 指向实际的网络服务器。
    3. 在服务器中,服务器场只有 1 个作为主站点的 ARR 条目。将此保留为默认值,但取消选中停止处理标志。为第一个重定向创建一个新的入站 URL 重写规则。将操作类型设为重定向(不是重写,这很重要。)
    4. 在默认网站下的代理上,为每个主机名创建绑定条目,设置端口相同,ip地址设置为*,然后另外创建一个相同的空白主机名。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2015-01-23
      • 2014-03-19
      • 2019-06-21
      • 1970-01-01
      • 2019-01-08
      • 1970-01-01
      • 1970-01-01
      • 2017-04-18
      相关资源
      最近更新 更多