【问题标题】:Installing SSL Certificate breaks PHP on WIMP安装 SSL 证书会破坏 WIMP 上的 PHP
【发布时间】:2012-01-04 07:07:19
【问题描述】:

我们有一个网站和几个子网站在 W2K3 标准服务器上运行。一切正常。 SSL 设置为过期,因此我们购买了新证书并更新了一个处理安全流量的子网站。一个 Web 运行 PHP 5.2.17,而带有证书的安全 Web 运行 PHP 4。? (出于向后兼容性的原因。)现在两个 Web 上的 PHP 都不起作用。特别是在 PHP 5 网页上,当我点击一个 PHP 页面时,甚至像回显“hello world”一样简单;它给出了错误“对内存位置的无效访问”。命中 PHP 4 站点时将给出消息“找不到指定的过程”。在尝试的解决方案中:重新启动受影响的网站、重新启动 IIS、重新启动服务器、验证 .php 指向 php5isapi.dll 的映射、删除和添加 PHP 4 和 5 的扩展(并验证两者都设置为允许)、回收应用程序池。在 Win 日志文件中看不到任何内容,也没有告诉 PHP INI 输出到文本日志文件。除了重新安装PHP之外还有什么可以做的吗? “唯一”的变化是安装了新证书,我们重新安装了旧证书只是为了排除新证书是问题。我说“仅”是因为我确信它做了一些事情,但我没有东西可以尝试。

【问题讨论】:

    标签: windows php wimp


    【解决方案1】:

    我在网上找到了一些关于降级 PHP 解决此问题的资源:

    http://lijumathew.wordpress.com/2009/10/15/php-throws-an-error-on-iis-invalid-access-to-memory-location/

    我想问你一些细节。你的W2K3服务器是标准版还是企业版? 32位还是64位?

    谢谢。

    【讨论】:

    • W2K3 标准 32 位。我确实看到了那篇博客文章,但我质疑它是我的情况的解决方案,因为 PHP 以前工作过。如果我在更新证书之前从未让它工作过,我会追求这个方向。另外,如果我要更新,我可能会选择最新的。
    • 也许你应该在 bugs.php.net 上提出问题。最近的版本不应该是最好的解决方案。很好的例子是 Redhat Enterprise OS 版本。请尝试降级,只是为了测试。还有一个需要注意的是,您可以比较以前和当前证书的参数吗? (密钥长度、算法、提供者等。)谢谢。
    • 我实际上并没有安装证书,所以我没有所有信息,但我知道提供商是不同的。他们从更昂贵的证书变成了更便宜的(尽管仍然众所周知)证书。我没有看到会要求特定类型证书的 PHP 设置?
    猜你喜欢
    • 1970-01-01
    • 2018-08-11
    • 1970-01-01
    • 2018-08-15
    • 2016-08-30
    • 1970-01-01
    • 2015-08-20
    • 2017-03-05
    • 1970-01-01
    相关资源
    最近更新 更多