【发布时间】:2012-11-19 03:12:34
【问题描述】:
我们使用 php 开发了一个 Web 应用程序。在客户将其迁移到 VMware 之前,它一直运行良好。因为在 POST 中发送的一些表单没有被发送,我们发现只有在发送超过一定数量的数据时才会发生这种情况。 只有在 VMware 环境中运行应用程序时才会发生这种情况。
请帮忙!!
更新: 在 apache_error.log 文件中,我发现了以下错误: PHP 警告:未知:输入变量超过 1000。增加限制更改 php.ini 中的 max_input_vars。在第 0 行的未知中,引用者:.....
这个参数只能在 php.ini-development 和 php.ini-production 中找到,它被注释了,所以我删除了 ;;并增加了值并在 php.ini 文件中添加了值,但正如我在 phpinfo() 中看到的那样,这一切都被忽略了 有什么建议吗?
PHP 版本 5.3.13
【问题讨论】:
-
多大才算太大? VMware 是在运行 Web 应用程序,还是只是托管运行 Web 应用程序的虚拟机?
-
如果内存不够,就是这样。检查error.log,我们不能。还有
post_max_size在 php.ini 等中。 -
我发现在 apache_error.log 中有一个错误:“输入变量超过 1000 所以需要更改 php.ini 中的 max_input_vars。好吧 - 我做了,但它被评论了,所以这就是意思被忽略了?它也不存在于生产和开发中的 php.ini 中,那么正确的位置在哪里?
-
@coder543 - 它是主机。有什么建议我应该更改哪个配置?