【问题标题】:Apache 2.4 - remove | delete | uninstallApache 2.4 - 删除 |删除 |卸载
【发布时间】:2016-05-08 19:48:54
【问题描述】:

我已经在网上搜索了很长时间,但我找不到如何完全删除 apache 2.4。

使用:
视窗 7
c:\apache24\

我已经尝试了所有命令,但没有任何效果。

httpd -k shutdown
httpd -k stop
httpd -k uninstall

继续获得相同的结果(对于每个命令):

<OS 5> access is denied.
failed to open the 'Apache2.4' service.

请注意,该服务仍在运行,
意味着 apache 仍在工作,
我得到“它有效!”在 localhost 中。

【问题讨论】:

    标签: apache uninstallation apache2.4 uninstallstring


    【解决方案1】:

    您可能在没有Administrator privileges 的情况下从终端运行这些命令。

    如果httpd -k uninstall由于某种原因无法正常工作,您应该可以通过sc命令删除服务:Sc delete,其他教程here。

    再次确保您以管理员身份运行这些命令。

    【讨论】:

      【解决方案2】:

      我遇到过这种问题。

      解决办法:

      cmd/powershell 
      

      以管理员身份运行!!! :D 结束!我总是忘记.....

      注意: 在 powershell 中需要放 .\ 例如:

      .\httpd -k shutdown
      .\httpd -k stop
      .\httpd -k uninstall
      

      结果:

      Removing the 'apache2.4' service
      The 'Apache2.4' service has been removed successfully.
      

      【讨论】:

        【解决方案3】:

        以管理员身份运行命令提示符并输入:

        C:\Apache24\bin>httpd -k uninstall
        

        在 Windows 10 中工作

        【讨论】:

          【解决方案4】:

          我注意到如果您没有将 Apache 添加到路径环境变量中(从任何文件夹/目录调用 Apache)。您必须 cd.. 到您的 Apache/bin 目录并运行
          .\httpd -k uninstall 来卸载。 (记得以管理员身份运行 PowerShell)

          【讨论】:

            猜你喜欢
            • 2013-03-22
            • 1970-01-01
            • 1970-01-01
            • 1970-01-01
            • 2010-09-16
            • 2014-04-04
            • 2013-12-10
            • 1970-01-01
            • 1970-01-01
            相关资源
            最近更新 更多